図形を入力し編集する時に知っていると便利なコツを集めてみました

トップ/ サポート/ TIPS/ 図形編集のコツ

Sonnetのプリプロセッサxgeomは, マイクロ波でよく使われるマイクロストリップ回路の導体パターンを描くために 考えられていますが,一般のプリント基板用CADとは操作や考え方が違うので 操作に戸惑う方が多いです.

ここではよく質問されたり,デモの時に実演すると感心していただけるような ちょっとしたコツを紹介します.

2014/2/19
石飛

v15,v16の新機能に合わせて修正しました.
2015/12/14 石飛

間違った図形編集を元に戻す

キーボードで コントロールキーとZを同時に押す

同じ機能を続けて使う

例えば,寸法線をあちこちに追加するなど,同じ機能を連続して使う場合は
[Shift]キーを押しながらメニューの項目を選ぶか
toolbarの機能をダブルクリックで選ぶと
[ESC]キーを押すまでその機能を連続して使うことができる.


長方形を描く

キーボードで コントロールキーとRを同時に押す


長方形を描きたい角で左クリックして、ちょっとマウスを動かす


キーボードで @x方向の寸法、y方向の寸法を入れてリターン (例えば @20,10)


図形をセルにあわせる

合せたい図形を囲むようにドラッグして選択(全部選びたければコントロールキーとAを同時に押す)


メニューの[Modify]-[Snap To...]


新しく開くダイアログの右のSnap Modeフレームの中の [Preserve shape and spaceing relative to the reference point](図形の形状を崩さない)のラジオボタンを選択する


[Select Reference Point](基準点を選ぶ]ボタンをクリック


図形の頂点をどれか左クリックする


[OK]ボタンをクリック


クリックした頂点がセルにスナップされる


図形をセンタリングする

合せたい図形を囲むようにドラッグして選択(全部選びたければコントロールキーとAを同時に押す)


メニューの[Modify]-[Center]-[Both](もちろん必要に応じてHorizontally,Verticallyでも)


図形の大きさとboxのセル数によってはセンタリングするとセルからはずれることがある.


図形を分割する

メニューの[Edit]-[Divide Polygons]を選ぶ. (必要に応じてその下の[Edit]-[Single Layer Divide]のチェックをはずすと、他の層も一気に分割できる)


マウスがカッターナイフの形になるので、切りたい線に沿ってドラッグする. (斜めカットはできません)


できあがり


複数の図形を一体化させる

一体化させたい図形を囲むようにドラッグして選択(全部選びたければコントロールキーとAを同時に押す)

メニューの[Edit]-[Boolean Operations]-[Union] を選ぶ.

V15以前のバージョンでは[Edit]-[Merge Polygons]

できあがり

複雑な図形を一気に一体化させると失敗することがあります.その場合は,部分的に少しずつ一体化してください.
特にgerberやdxfファイルから変換した場合は見えない頂点が複雑に入り組んでいる場合が多く注意が必要です.

中抜き図形を描く

外側の図形をクリックして選びます.

メニューの[Edit]-[Boolean Operations]-[Substract] を選ぶ.

内側の図形を選び,[Enter]キーを押します.

内側の図形は外側の図形と重なり合っているので,クリックでは選びにくい場合があります.ドラッグで囲むほうが選びやすいかもしれません.

できあがり

中抜き図形を描く方法(V15以前のバージョン)

fig6 不要な導体パターンを削除する

V15以前のバージョンでは次の方法で 中抜き図形を描くことができます.

非常に導電率の低い導体材料を定義する

fig3 導体材料の定義 まず,非常に導電率の低い(抵抗率の高い)導体材料を定義します. [Circuit]-[Metal types]で右のダイアログを開きます.

次に[Add Planner...]ボタンであたらしい導体材料の定義を始めます.

fig4 損失の大きい導体材料の定義

例えば右図のように非常に導電率の低い導体材料を定義します.

導体パターンに導体材料を指定する.

fig2 差し引く導体パターン

ここでは例として図のように緑の導体パターンから赤い導体パターンを差し引くとします.

表のように各導体パターンに導体材料を指定します.

a 導体材料
差し引かれる導体パターン 非常に導電率の低い導体材料 例えば lossy
差し引く導体パターン 通常の導体材料 例えば lossless

導体パターンに導体材料を設定するには

  1. 指定したい導体パターンを選択します.
  2. 導体パターン上で右クリックします
  3. [metal properties]を選択し
  4. ダイアログのMetalの項目の右の導体材料の名前を選択します.
  5. ダイアログを閉じる

図形を一体化させる..

fig5 EDIT-Mergeの結果 メニューから[Edit]-[Merge]を選ぶと右図のようになります. 不要な導体パターンを削除してください.

[Edit]-[Select Matching Metal Polygons...]を使うと特定の導電材料の導体パターンだけを選択できます.

複雑な形状のviaあるいは金属ブロックを作る

viaの形状をまず、金属図形として作り、その図形を選択します.


その図形を[Edit]-[Copy]でクリップボードにコピーします.
そして[View]-[Down one level]で下の層に移動し
[Edit]-[Paste]でクリップボードからペーストします.


[Modify]-[Convert to Via Polygon]を選びます.


図形の周囲がviaに変換されます.


最初の金属板がviaの蓋になり、全体が金属ブロックになります.


図形の修正

修正したい図形を選びます.

四角い頂点をドラッグすると,図形を伸ばしたり縮めたりできます.長方形はもちろん,図のように斜めの線路も線路幅を保ったまま長さを変更できます.

丸い頂点をドラッグすると,図形を拡大縮小,変形できます.

複雑な形状の図形,特に外部からインポートした図形には 意図しない頂点が含まれていて 上の方法ではうまくいかないことがあります.

メニューの[Tools]-[Edit Points]を選びます.

V14以前のバージョンでは[Tools]-[Reshape]
これで図形を選択するモードから 頂点を一つ一つ選択し,削除追加できるモードになります.

意図しない頂点を[Del]キーで削除しましょう.逆に頂点を追加するのは メニューの[Tools]-[Add Points to Polygon]です.

右の例では矢印で示した頂点はおそらく意図しない頂点です.

寸法の文字サイズの変更

注意この方法は推奨されません. 操作を間違えると再インストールが必要になります.

Sonnet Tool Barのメニューから [Admin]-[Diagnostics]-[Edit sonnet.ini File]を選んでください.
たぶんメモ帳でsonnet.iniファイルが開きます.


スクロールして[Xgeom]で始まる行を探してください.
[Xgeom]で始まる行の下に "DimLabelFontSize="で文字のサイズを指定します.
保存してメモ帳を閉じてください.


Xgeomを再起動すると,sonnet.ini ファイルに従って寸法文字の大きさが変わっています.


極端に細長いモデルの表示

モデルが極端に細長くて取り扱いが難しい場合は メニューの[View]-[Aspect Ratio...]を押し, x,y方向の表示倍率の比率を変えると操作が楽になる.