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Chapter 6 GDSII and DXF 
Translator Tutorial

このﾁｭｰﾄﾘｱﾙでは GDSII 或いは DXF のﾌｧｲﾙを Sonnet ﾌﾟﾛｼﾞｪｸﾄの中へ変換
する上での基本的な事柄を説明します。この 2つのﾌｧｲﾙ変換の操作は大
変似ているので、異なる部分は別々に説明しますが、この 2つを 1つの
ﾁｭｰﾄﾘｱﾙにまとめました。 GDSII 及び DXF のﾌｧｲﾙ変換についての詳細は、
Sonnet User’s Guideの第 15章 “The DXF and GDSII Translators”をご覧くだ
さい。 

このﾁｭｰﾄﾘｱﾙではｼﾝﾌﾟﾙな例題を取り扱います。この例題ﾌｧｲﾙはこの
ｿﾌﾄｳｪｱに付録の examples ( 例題 ) ﾃﾞｨﾚｸﾄﾘ の中にあり、 DXF変換ｿﾌﾄ用に
は “dcblock.dxf”、GDSII変換ｿﾌﾄ用には “dcblock.gds ”が用意されていま
す。 
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これらのﾌｧｲﾙは DXF 及び GDSIIのﾌｧｲﾙで、同じ 2つの回路を含みます。
以下に示す、DC ﾌﾞﾛｯｸとして使用される 1つの結合線路構造と曲がり部
のある 1つの伝送線路です。この例題の目的は、DXF ﾌｧｲﾙまたは GDSII 
ﾌｧｲﾙを Sonnet ﾌﾟﾛｼﾞｪｸﾄの中に変換し、DC ﾌﾞﾛｯｸが emで解析できるよう
にそのﾌｧｲﾙを微調整することです。

DXF及びGDSII の例題ﾌｧｲﾙには2つの回路が含ま
れており、この例題では上の回路を使用します。
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Obtaining the Translator Example Files
Sonnetの例題から Dcblock をｺﾋﾟｰする必要があります。Dcblock はﾃﾞｨﾚｸﾄﾘ
で、ここにはこの例題で入力に使用される DXF 及び GDSII ﾌｧｲﾙと、変
換のためのﾚｲﾔﾏｯﾋﾟﾝｸﾞﾌｧｲﾙが含まれています。Sonnet の例題の入手方法に
ついては、いずれかのﾌﾟﾛｸﾞﾗﾑﾒﾆｭｰから Help ⇒ Examples を選択し、 次に
Instructions ﾎﾞﾀﾝをｸﾘｯｸします。 PDFﾌｫｰﾏｯﾄを使ってこのﾏﾆｭｱﾙをお読みに
なっている場合は、上の青色のﾘﾝｸをｸﾘｯｸしてください。

Determine Level Mapping 
まず、project editorのﾚﾍﾞﾙに対して DXF ﾚｲﾔのﾏｯﾋﾟﾝｸﾞを定義する必要が
あります。このために、ﾃﾞﾌｫﾙﾄの ﾚｲﾔﾏｯﾋﾟﾝｸﾞが設定されている DXF 
ﾌｧｲﾙをｲﾝﾎﾟｰﾄします。その結果できたﾌﾟﾛｼﾞｪｸﾄを使用して、 DXF ﾌｧｲﾙか
らどのﾚｲﾔを残すのかを決定します。同じﾌｧｲﾙで 2回めのｲﾝﾎﾟｰﾄを実行
します。今回は Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの内容を修正し、次に続く
ｲﾝﾎﾟｰﾄで使用するために、その設定内容を ﾚｲﾔﾏｯﾋﾟﾝｸﾞﾌｧｲﾙに保存しま
す。 

NOTE: この例題ではﾚｲﾔﾏｯﾋﾟﾝｸﾞを修正していますが、これは多くの DXF ﾌｧｲﾙに
は必要でないかもしれません。DXF 変換ｿﾌﾄによって作成されたﾃﾞﾌｫﾙﾄ
のﾏｯﾌﾟで十分でしょう。 

1 Project editorを起動します。

Project editor ｳｨﾝﾄﾞｳが表示されます。

2 Project editorのﾒｲﾝﾒﾆｭｰから、ご使用の変換ｿﾌﾄによって File ⇒ Import 
⇒ DXF または File ⇒ Import ⇒ GDSIIを選択します。

ﾌﾞﾗｳｻﾞｳｨﾝﾄﾞｳが表示されます。
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3 お使いのﾜｰｷﾝｸﾞﾃﾞｨﾚｸﾄﾘに例題ﾌｧｲﾙの “dcblock.dxf” または “dcblock.gds” 
を置き、ﾌﾞﾗｳｻﾞ ｳｨﾝﾄﾞｳの Open ﾎﾞﾀﾝをｸﾘｯｸします。

Import Control ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

この例題では、ﾌｧｲﾙ “dcblock.dxf” または “dcblock.gds”を新しい Sonnet の
ﾌﾟﾛｼﾞｪｸﾄ “dcblock.son”へｲﾝﾎﾟｰﾄします。ﾃﾞﾌｫﾙﾄのｵﾌﾟｼｮﾝは新しい
ﾌﾟﾛｼﾞｪｸﾄへｲﾝﾎﾟｰﾄすることになっており、ﾃﾞﾌｫﾙﾄのﾌﾟﾛｼﾞｪｸﾄ名は DXF
または GDSII ﾌｧｲﾙ のﾍﾞｰｽﾈｰﾑに、Sonnetのﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙであることを示
す拡張子 “.son” がつきます。このﾃﾞﾌｫﾙﾄの内容がここで行ないたいこと
なので、ここでは何もする必要はありません。

NOTE: GDSII ﾌｧｲﾙをｲﾝﾎﾟｰﾄしている場合は、次のStep4に進んでください。 DXF 
ﾌｧｲﾙをｲﾝﾎﾟｰﾄしている場合は、108 ﾍﾟｰｼﾞの Step7へ進んでください。 
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4 Import Control ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Next ﾎﾞﾀﾝをｸﾘｯｸして、次へ進みます。 

Structure ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

この例題では GDSII ﾌｧｲﾙには 1つの structure しかありません。従って、
ﾃﾞﾌｫﾙﾄの structure を変換するというﾃﾞﾌｫﾙﾄのｵﾌﾟｼｮﾝが使えます。ｲﾝﾎﾟｰﾄ
している GDSII ﾌｧｲﾙが複数の structureを持っている場合には、“Specify 
Structure” ｵﾌﾟｼｮﾝを選択することができます。これで Specify ﾎﾞﾀﾝが使用
可能になります。このﾎﾞﾀﾝをｸﾘｯｸすると、 GDSII ﾌｧｲﾙで使用できる
structure のﾘｽﾄが表示されます。 Sonnet のﾌﾟﾛｼﾞｪｸﾄへ変換したいstructureを
選択することができます。 
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5 Structure ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Next ﾎﾞﾀﾝをｸﾘｯｸして続行します。

“Reading Layers, please wait.”というﾒｯｾｰｼﾞがImport Control ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽに
表示されます。 Project editor が GDSII ﾌｧｲﾙからﾚｲﾔの情報を入手し終わる
と、Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

ﾕｰｻﾞは project editorで変換されたﾌｧｲﾙを見るまでは、何のﾏｯﾋﾟﾝｸﾞがほし
いのかわからないので、ここではこのﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの中で何も変更する
必要はありません。
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6 Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Next ﾎﾞﾀﾝをｸﾘｯｸして続行します。

Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に 表示されます。

“Ready to Import” というﾒｯｾｰｼﾞが出力ｳｨﾝﾄﾞｳに表示されます。ﾃﾞﾌｫﾙﾄの
ｵﾌﾟｼｮﾝの設定内容が、このﾌｧｲﾙで使用したい設定内容なので、 Import 
Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｵｰﾌﾟﾝする必要はありません。Import Optionsの設
定についての情報は、 project editorのﾍﾙﾌﾟをご覧ください。

NOTE: 109 ﾍﾟｰｼﾞの Step8へ進んでください。
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7 Import Control ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Next ﾎﾞﾀﾝをｸﾘｯｸして続行します。

Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

“Ready to Import” というﾒｯｾｰｼﾞが出力ｳｨﾝﾄﾞｳに表示されます。ﾃﾞﾌｫﾙﾄの
ｵﾌﾟｼｮﾝの設定内容が、このﾌｧｲﾙで使用したい設定内容なので、 Import 
Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｵｰﾌﾟﾝする必要はありません。Import Optionsの設
定についての情報は、 project editorのﾍﾙﾌﾟをご覧ください。
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8 Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Import ﾎﾞﾀﾝをｸﾘｯｸし、変換を実行します。

経過を示すﾒｯｾｰｼﾞが出力ｳｨﾝﾄﾞｳの上に表示されます。ｲﾝﾎﾟｰﾄが終了する
と、出力ｳｨﾝﾄﾞｳに DXF または GDSII ﾌｧｲﾙの情報が表示されます。

DXF の情報

GDSII の情報
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9 Close ﾎﾞﾀﾝをｸﾘｯｸして Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞします。

目的のﾌﾟﾛｼﾞｪｸﾄ “dcblock.son” が project editorにｵｰﾌﾟﾝします。

Project editorで回路の各ﾚﾍﾞﾙを見てみましょう。ｾﾙｻｲｽﾞがまだ定義されて
いないので、回路を見ることは難しいかもしれません。ﾕｰｻﾞの判断で
(^Mを使って ) この例題の残りの場面で、ｾﾙﾌｨﾙ ( ｾﾙの充填 )を “on”に
したり、 “off”にします。

いくつかのﾚｲﾔがあることに注目してください。 Project editorのﾚﾍﾞﾙ 5 は、
emの解析に必要なすべての情報を持っています。変換でこのﾚｲﾔのみを
使用するように、 Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽでﾚｲﾔﾏｯﾋﾟﾝｸﾞを修正してく
ださい。これを行なうには、ﾌｧｲﾙを再度ｲﾝﾎﾟｰﾄしますが、ｲﾝﾎﾟｰﾄする前
に Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを修正します。 

10 Project editorのﾒｲﾝﾒﾆｭｰから File ⇒ Import ⇒ DXF または File ⇒ Import 
⇒ GDSII を選択します。

ﾌﾞﾗｳｻﾞ ｳｨﾝﾄﾞｳがｵｰﾌﾟﾝします。 

11 Once例題ﾌｧｲﾙ “dcblock.dxf” または “dcblock.gds” を置いたら、Open 
ﾎﾞﾀﾝをｸﾘｯｸします。

Import Control ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。
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12 Import to Present Project ｵﾌﾟｼｮﾝを選択します。

これで DXF または GDSII を前と同じﾌﾟﾛｼﾞｪｸﾄへｲﾝﾎﾟｰﾄします。

NOTE: GDSII ﾌｧｲﾙをｲﾝﾎﾟｰﾄしている場合は、以下のｽﾃｯﾌﾟ 13へ進んでください。 
DXF ﾌｧｲﾙをｲﾝﾎﾟｰﾄしている場合は、113 ﾍﾟｰｼﾞの Step20 へ進んでくださ
い。 

13 Import Control ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Next ﾎﾞﾀﾝをｸﾘｯｸして続行します。

Structure ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。ﾃﾞﾌｫﾙﾄの structure は正し
いものです。

14 Structure ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Next ﾎﾞﾀﾝをｸﾘｯｸして続行します。

Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽがｵｰﾌﾟﾝします。ﾕｰｻﾞはﾚｲﾔ 8 が em の解析に
必要なすべての情報を持っていることを知っているので、変換でこの
ﾚｲﾔのみを使用するようにこのﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの入力項目を修正します。

15 GDSII Streamﾅﾝﾊﾞｰ8 を含む列以外のすべての列の Map ﾁｪｯｸﾎﾞｯｸｽをｸﾘｯｸ
します。 

これで stream layer 8が、 変換で使用される唯一のﾚｲﾔとして残されます。
他のﾚｲﾔは、Mapのﾁｪｯｸﾎﾞｯｸｽが offになっているので無視されます。ﾚｲﾔ
が多くてそのすべてを表示できないので、ｽｸﾛｰﾙﾊﾞｰを使って、現在は表
示されていないﾚｲﾔにｱｸｾｽします。

16 ｽﾄﾘｰﾑﾅﾝﾊﾞｰ 8 の入力に、Xgeom Level ﾃｷｽﾄ入力ﾎﾞｯｸｽの中に “0” と入力し
ます。

この例題は 1つのﾚｲﾔの回路なので、 Xgeom Level の数に project editorで
は最初のﾚﾍﾞﾙである “0” を入力します。 
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17 同じ列の Xgeom Materialの欄に “Copper” と入力します。

Xgeom Object typeとしてMetal が既に選択されています。使用したい金属
の種類は copperです。金属 “copper” はﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙでは定義されていな
いので、後でこの特性を定義する必要があります。Layer Mapping 
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽは以下のように表示されているはずです。

このﾌｧｲﾙの将来のｲﾝﾎﾟｰﾄで使用するために、この設定内容を保存したい
場合は、Save ﾎﾞﾀﾝをｸﾘｯｸすると、この設定内容を外部のﾚｲﾔﾌｧｲﾙへ保存
できます。 外部のﾚｲﾔﾌｧｲﾙをﾛｰﾄﾞするためには、load ﾎﾞﾀﾝをｸﾘｯｸします。

18 Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの OKをｸﾘｯｸして続行します。

19 Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Import をｸﾘｯｸし、このｲﾝﾎﾟｰﾄを終了します。

ｲﾝﾎﾟｰﾄが終了したら、 Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Close ﾎﾞﾀﾝをｸﾘｯｸします。 
ﾌｧｲﾙ “dcblock.son” が project editorの中にｵｰﾌﾟﾝされるはずです。

NOTE: GDSII ﾌｧｲﾙをｲﾝﾎﾟｰﾄしている場合は、115 ﾍﾟｰｼﾞの “Define Dielectric 
Layer and Metallizations“に進んでください。
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20 （DXFの続き）Import Control ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Next ﾎﾞﾀﾝをｸﾘｯｸして、続
行します。

Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示され、 DXF変換ｿﾌﾄによってこのﾌｧｲﾙか
らﾚｲﾔが読み込まれたという意味のﾒｯｾｰｼﾞが表示されます。

21 Layers ﾎﾞﾀﾝをｸﾘｯｸして、 Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｵｰﾌﾟﾝします。

Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽがｵｰﾌﾟﾝします。ﾕｰｻﾞはﾚｲﾔ 5 が em の解析に
必要なすべての情報を持っていることを知っているので、変換でこの
ﾚｲﾔのみを使用するようにこのﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの入力項目を修正します。

22 Xgeom level 5を含む列以外のすべての列の Map ﾁｪｯｸﾎﾞｯｸｽをｸﾘｯｸします。 

これで DXF ﾚｲﾔ “Filter” が、 変換で使用される唯一のﾚｲﾔとして残されま
す。他のﾚｲﾔは、Mapのﾁｪｯｸﾎﾞｯｸｽが offになっているので無視されます。
ﾚｲﾔが多くてそのすべてを表示できないので、ｽｸﾛｰﾙﾊﾞｰを使って、現在
は表示されていないﾚｲﾔにｱｸｾｽします。

23 DXF ﾚｲﾔ “Filter”入力のために、 Xgeom Level ﾃｷｽﾄ入力ﾎﾞｯｸｽの中に “0” と
入力します。

この例題は 1つのﾚｲﾔの回路なので、 Xgeom Level の数に project editorで
は最初のﾚﾍﾞﾙである “0” を入力します。 
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24 同じ列の Xgeom Materialの欄に “Copper” と入力します。

Xgeomの Object typeとしてMetal が既に選択されています。使用したい金
属の種類は copperです。金属 “copper” はﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙでは定義されてい
ないので、後でこの特性を定義する必要があります。Layer Mapping 
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽは以下のように表示されているはずです。

このﾌｧｲﾙの将来のｲﾝﾎﾟｰﾄで使用するために、この設定内容を保存したい
場合は、Save ﾎﾞﾀﾝをｸﾘｯｸすると、この設定内容を外部のﾚｲﾔﾌｧｲﾙへ保存
できます。 外部のﾚｲﾔﾌｧｲﾙをﾛｰﾄﾞするためには、load ﾎﾞﾀﾝをｸﾘｯｸします。

25 Layer Mapping ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの OKをｸﾘｯｸして続行します。

Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽに戻ります。

26 Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Options ﾎﾞﾀﾝをｸﾘｯｸします。
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Import Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。この例題はﾐｸﾛﾝの単
位で入力されました。ﾃﾞﾌｫﾙﾄの Units ( 単位 )はｲﾝﾁなので、回路を
ｲﾝﾎﾟｰﾄする前に、この単位を変更する必要があります。

27 Units ﾄﾞﾛｯﾌﾟﾘｽﾄから “microns” を選択します。

これにより DXF 変換ｿﾌﾄは、 DXF ﾌｧｲﾙをｲﾝﾎﾟｰﾄする時に長さの単位とし
てﾐｸﾛﾝを使います。

28 OK ﾎﾞﾀﾝをｸﾘｯｸして、この変更事項を適用します。

Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽがｸﾛｰｽﾞします。これで DXF ﾌｧｲﾙをｲﾝﾎﾟｰﾄする準備
ができました。

29 Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Import をｸﾘｯｸし、このｲﾝﾎﾟｰﾄを終了します。

ｲﾝﾎﾟｰﾄが終了したら、 Import ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Close ﾎﾞﾀﾝをｸﾘｯｸします。 
ﾌｧｲﾙ “dcblock.son” が project editorの中にｵｰﾌﾟﾝされるはずです。

Define Dielectric Layer and Metallizations
次に、 project editorの中で金属導体と誘電体層のﾊﾟﾗﾒｰﾀを定義します。手
順は、通常のﾌﾟﾛｼﾞｪｸﾄでこれらの修正を行なうのと同じです。
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この例題では、 Dielectric Layers ﾀﾞｲｱﾛｸﾞで一番上の誘電体層に 1000 ﾐｸﾛﾝ
の空気 (Erel=1.0) を設定し、底部の誘電体層に 100 ﾐｸﾛﾝの GaAs 
(Erel=12.9) を設定します。また、 Metal Types ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽで、 Normal の
金属ﾀｲﾌﾟを使い、Copperの導電率を 5.8E7 S/mに、厚さを 15 ﾐｸﾛﾝに、電
流比率を 0に設定します。

Remove Parts of the Circuit Not Being Used
ﾃﾞﾘｰﾄ（削除 )やｸﾘｯﾌﾟ ( 切り取り )を行なう前に、ﾌｧｲﾙを保存したい時
があるかもしれません。 

em で解析したい回路よりもかなり多くの部分を変換してしまっている
ことがあるかもしれません。その場合、複数のﾚﾍﾞﾙから回路の大きな部
分を削除したくなるでしょう。 Circuit ⇒ Dielectric Layersを使って、全体
のﾚﾍﾞﾙを削除する必要も出てくるかもしれません。今回の例題では、 必
要ない余分なﾚｲﾔを削除するために Layer Mapping ﾀﾞｲｱﾛｸﾞを使いました
が、すべての誘電体層がｲﾝﾎﾟｰﾄされました。 金属を持たない誘電体層は、
解析時間や必要ﾒﾓﾘ容量に影響しないので、どちらの方法も使えます。

Edit ⇒ Clip を使って、回路の解析した部分以外を枠外で削除します。
特定の領域を枠外で削除するためには、 Edit ⇒ Clipを選択する前に
ｽﾅｯﾌﾟを offにする必要があります。

Select ⇒ Single Layer または Select ⇒ Mult. Layer を使い、いくつかの図
形と点を選択することによって、一度にいくつかの図形を削除すること
もできます。 “Delete” ｷｰを押して、選択された点を削除します。結果に影
響を与えない金属を除去することのできる場所は、emの実行時間を短
縮するということを覚えておいてください。
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この例題では、ﾌｧｲﾙを保存した後に以下に示すように Edit ⇒ Clip を使
用します。 RF ﾌﾟﾛｰﾌﾞ構造は、測定でｷｬﾘﾌﾞﾚｰｼｮﾝによってはずされるの
で、 emの解析に含むべきではありません。

Decide on a Substrate Size and Cell Size
図形をもとにして、ｾﾙｻｲｽﾞや基板のｻｲｽﾞを決定するべきです。まず、領
域のｻｲｽﾞをｾﾙｻｲｽﾞの倍数に設定することを覚えておいてください。回路
の大部分を削除してしまっているので、基板のｻｲｽﾞを変更する必要があ
ります。 
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次に基板のｻｲｽﾞを設定します。Circuit ⇒ Box を選択して Box Settings 
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｵｰﾌﾟﾝします。続いて Set Box Size with Mouse ﾎﾞﾀﾝをｸﾘｯｸ
し、残りの回路のまわりの領域をﾗｯｿ ( 囲い込み )します。これは、
ﾎﾞｯｸｽのｻｲｽﾞが最終的なﾎﾞｯｸｽのｻｲｽﾞにほぼ “近く ”なるように行なうも
のです。

次に Box Settings ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽのﾃｷｽﾄ入力ﾎﾞｯｸｽの中に値を入力すること
により、ﾎﾞｯｸｽの x の寸法を 1,800 ﾐｸﾛﾝ、ﾎﾞｯｸｽの y の寸法を 800 ﾐｸﾛﾝに正
確に設定します。続いて、ｾﾙｻｲｽﾞを 10 ﾐｸﾛﾝ x 10 ﾐｸﾛﾝに設定します。先
程、基板のｻｲｽﾞをｾﾙｻｲｽﾞの倍数にしたことに注目してください。 OK ﾎﾞﾀﾝ
をｸﾘｯｸして、新しいﾎﾞｯｸｽｻｲｽﾞを適用し、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞします。

Change Polygons to Have the Proper Fill
必要であれば、図形の fill ( ｻﾌﾞｾｸｼｮﾝの種類 )を変更します。例えば、い
くつかの図形を Staircase fill ( 階段状充填 )から Diagonal fill( 斜め線状充
填 )に変更する必要があるかもしれません。一度にいくつかの図形を変
更するためには、複数の図形を選択し、次に Modify ⇒ Metal Properties
を選ぶことができます。

この例題では、図形の fill を変更する必要はありません。
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Align the Circuit to Grid Points
それでは、 em がどのように回路をｻﾌﾞｾｸｼｮﾝ ( 分割 )するのかを見てみま
しょう。これを行うには、 cell fillが “on”になっていることを確認しま
す。 cell fill は em がどのように回路をｻﾌﾞｾｸｼｮﾝするかを示します。十分に
小さなｾﾙｻｲｽﾞになっていなかったり、回路が正確にｸﾞﾘｯﾄﾞ点上に置かれ
ていないと、金属は 2つの図形を共に “ ｼｮｰﾄ ( 短絡 )”してしまうかもし
れません。この例題では、以下に図解するようにそれが生じます。この
図では、回路全体をわずかにずらすと、この問題は解決されます。

この例題では、Tools ⇒ Snap Setup を使って Snap Grid Setup ﾀﾞｲｱﾛｸﾞ　
ﾎﾞｯｸｽをｵｰﾌﾟﾝし、ｾﾙのｽﾅｯﾌﾟを offにします。 No Snap ﾗｼﾞｵﾎﾞﾀﾝをｸﾘｯｸし、
ｽﾅｯﾌﾟを offにします。 OK ﾎﾞﾀﾝをｸﾘｯｸして、この変更事項を適用し、
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞします。次に Edit ⇒ Select Allを使って、ｸﾞﾘｯﾄﾞ上

Shorted Polygons
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に正しく置かれるように回路を移動します。回路が正確に置かれるかに
ついては心配する必要はありません。この図形はもはや “ ｼｮｰﾄ ( 短絡 )” 
してはいないことに注目してください。

TIP
ｺﾏﾝﾄﾞ Edit ⇒ Select Allの代わりに、ｼｮｰﾄｶｯﾄｷｰの ctrl-A を使えます。 

この時点で、すべての図形をｸﾞﾘｯﾄﾞ上にｽﾅｯﾌﾟしたいでしょう。ｽﾅｯﾌﾟを
する前に、ﾌｧｲﾙを保存したくなるかもしれません。すべての図形を選択
します。 ﾒﾆｭｰからModify ⇒ Snap to を選択します。そこで表示された 
Snap Objects ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Cells ｾｸｼｮﾝの X と Y のﾗｼﾞｵﾎﾞﾀﾝをｸﾘｯｸしま
す。 次に Preserve Spacing and Shape Relative to the Reference Point ﾗｼﾞｵﾎﾞﾀﾝ
を選択します。 Select Reference Point をｸﾘｯｸし、回路の中で参照点を選択
します。回路の他のすべての頂角がこの参照点の位置に相対的にｽﾅｯﾌﾟ
され、ｲﾝﾎﾟｰﾄされた回路の形状が維持されます。 ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが再び表
示されたら OK ﾎﾞﾀﾝをｸﾘｯｸしてﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞし、この回路を
ｸﾞﾘｯﾄﾞ点にｽﾅｯﾌﾟします。 

もしお望みであれば、回路の一部を選択して、ｸﾞﾘｯﾄﾞ点にｽﾅｯﾌﾟするこ
とができます。
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Move Points Around as Needed
いくつかの点はここで移動する必要があるかもしれません。三角形の角
と細い線、そしてｷﾞｬｯﾌﾟ部には特に注意を払ってください。 

この例題ﾓﾃﾞﾙは、中央に置く必要があります。ｽﾅｯﾌﾟがｾﾙｽﾅｯﾌﾟに設定さ
れる (Tools ⇒ Snap Setup を選択し、 Cell Sizeを選ぶ )ことを確認し、 
Edit ⇒ Select Allを選びます。ここで回路を基板のほぼ中央に移動しま
す。

Add Vias
次に、必要に応じて viaを追加します。標準の DXF ﾌｧｲﾙに保存されてい
る金属導体はﾏｽｸの寸法とﾚｲﾔを表現しているだけで実際の寸法や viaの
位置ではありません。 手入力で各 viaをつくる必要があるかもしれませ
ん。この例題では、 viaは必要ではありません。
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Add Ports and Reference Planes
例題を終了するために、ﾎﾟｰﾄと参照面を追加します。通常、これは 
Tools ⇒ Reshape と Modify ⇒ Snap Toを使用し、回路を縁の外に出すため
には、伝送線路を広げる必要があります。完成した回路を以下に示しま
す。

これでこの回路を em で解析することができます。 10 GHzで解析すると、
およそ 200 ｻﾌﾞｾｸｼｮﾝになるはずです。




