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Chapter 5 Microwave Office 
Interface Tutorial

Introduction
高周波設計ﾂｰﾙの相互運用性に向けて大きく前進するために、 Applied 
Wave Research (AWR) 社は、 Microwave Office 6.0 以上の EM Socket をご提
供しました。これにより、完全に統合された "solver on request( ﾘｸｴｽﾄﾍﾞｰｽ
のｿﾙﾊﾞｰ）" をご利用になれます。お好みの設計ﾌﾛｰを選び、基準の設計
とﾕｰｻﾞのﾚｲｱｳﾄの一部である EM（電磁界）ﾓﾃﾞﾙ構造を合わせて進めるこ
とができます。 

Sonnet はこれを機に Microwave Office 6.0 以上の環境の中に Sonnetの国際
的ﾚﾍﾞﾙの電磁界設計ｴﾝｼﾞﾝ emを組み込むことを可能にするMicrowave 
Office Interface (MOI) を作成しました。ﾕｰｻﾞは Sonnetのｲﾝﾀﾌｪｰｽを習得し
なくても、Sonnetの高精度な解析をご利用になれます。統合された環境
としてはまだｻﾎﾟｰﾄされていませんが、強力で高度な機能を利用された
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い上級のﾕｰｻﾞのために、AWR 社と Sonnet社は連携して、電磁界
ﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙを、  Microwave Office と Sonnetで行き来できるように、
ﾌﾟﾛｾｽを簡素化しています。 

Microwave Office Interfaceとその操作のﾓｰﾄﾞ及び変換についての詳細は、 
Sonnet User’s Guideの第14章"Microwave Office Interface"をご覧ください。 

Microwave Office Interface (MOI) ﾁｭｰﾄﾘｱﾙは、  Sonnet と AWR社の 
Microwave Officeの概観がわかるように作られています。このﾁｭｰﾄﾘｱﾙは、
ﾕｰｻﾞが  Sonnet と Microwave Officeの基本的な使い方に慣れているものと
仮定しています。慣れていない場合は、適切なﾄﾞｷｭﾒﾝﾃｰｼｮﾝをご参照く
ださい。Sonnetを初めてお使いになる場合は、 Sonnet Tutorial ﾏﾆｭｱﾙの
ﾁｭｰﾄﾘｱﾙをお読みください。これは、印刷されたﾏﾆｭｱﾙの中に含まれてい
るか、このﾁｭｰﾄﾘｱﾙを読む前に Sonnet ﾀｽｸﾊﾞｰから PDF ﾌｫｰﾏｯﾄで入手する
ことができます。 

Tutorial Topics
次のことがこのﾁｭｰﾄﾘｱﾙで説明されています。

• Microwave Officeでの編集、 Sonnetでの編集、Microwave office
の外での使い方。

• Microwave Officeの中から Sonnetのproject editorをｵｰﾌﾟﾝする。

• Sonnetの解析ｴﾝｼﾞﾝのための Adaptive Band Synthesis ｽｨｰﾌﾟを
設定する。

• Sonnetの解析ｴﾝｼﾞﾝ emを使って、Microwave Office の中で
ｼﾝﾌﾟﾙな解析をする。

• Microwave Office と Sonnetの両方で結果のﾃﾞｰﾀを見る。

• Microwave Officeから Sonnet ﾌﾟﾛｼﾞｪｸﾄに EM ﾓﾃﾞﾙ構造を
ｴｸｽﾎﾟｰﾄする。

• Sonnet ﾌﾟﾛｼﾞｪｸﾄを Microwave Officeにｲﾝﾎﾟｰﾄする。
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Obtaining the Example Project
Sonnet ｿﾌﾄｳｪｱのｲﾝｽﾄﾚｰｼｮﾝには、このﾁｭｰﾄﾘｱﾙの Microwave Office の例題
ﾌﾟﾛｼﾞｪｸﾄが用意されており、お使いのｺﾝﾋﾟｭｰﾀ上で PDFのﾏﾆｭｱﾙをご利用
になれます。 ｺﾝﾋﾟｭｰﾀ上で PDF ﾌｫｰﾏｯﾄでご覧になっている Application 
Examples interfaceを使って、例題ﾌﾟﾛｼﾞｪｸﾄを直接 Microwave Officeにﾛｰﾄﾞ
することができます。 

NOTE: PDF ﾌｫｰﾏｯﾄの例題ｲﾝﾀﾌｪｰｽを使うにはお使いのｼｽﾃﾑに  Adobe Acrobat 
Reader がｲﾝｽﾄｰﾙされている必要があります。このﾌﾟﾛｸﾞﾗﾑをお持ちでな
ければ、Sonnet ﾀｽｸﾊﾞｰのﾒｲﾝﾒﾆｭｰから Admin ⇒ Install Acrobat を選択す
ると、ｲﾝｽﾄﾚｰｼｮﾝできます。

ﾁｭｰﾄﾘｱﾙで使用する Lowpass ﾌﾟﾛｼﾞｪｸﾄをｺﾋﾟｰするには次のようにします。

1 Sonnet ﾀｽｸﾊﾞｰの Manuals ﾎﾞﾀﾝをｸﾘｯｸします。

ﾌｧｲﾙ sonnet_online.pdf が画面に表示されます。 

2 PDF ﾄﾞｷｭﾒﾝﾄの Application Examples ﾎﾞﾀﾝをｸﾘｯｸします。

3 Complete List ﾎﾞﾀﾝをｸﾘｯｸします。 

全例題ﾌｧｲﾙがｱﾙﾌｧﾍﾞｯﾄ順に並んだﾍﾟｰｼﾞが表示されます。

4 そのﾘｽﾄの  Lowpass をｸﾘｯｸします。

これで、Application Examplesの Microwave Office の例題ﾌﾟﾛｼﾞｪｸﾄに入り
ます。 
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5 このﾍﾟｰｼﾞの上の Load into Microwave Office ﾎﾞﾀﾝをｸﾘｯｸします。

Microwave Office が起動され、ﾌﾟﾛｼﾞｪｸﾄ "lowpass.emp" が画面に表示され
ます。下図のように表示されるはずです。

6 ﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞｳｨﾝﾄﾞｳのCircuit Schematicsの下にある "3 Stage Low Pass 
Filter"をﾀﾞﾌﾞﾙｸﾘｯｸします。

この回路は、3つのﾓﾃﾞﾙ構造を接続して、 EM ﾓﾃﾞﾙ構造の "Low Pass Filter" 
を使います。

7 ﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞｳｨﾝﾄﾞｳの Graphsの下にある "Graph 1" をﾀﾞﾌﾞﾙｸﾘｯｸしま
す。

Microwave Office ｳｨﾝﾄﾞｳにｸﾞﾗﾌが表示されます。Microwave 
Office ﾌﾟﾛｼﾞｪｸﾄではまだ解析が行われていないのでｸﾞﾗﾌには何も表示さ
れていません。

Project ﾌﾞﾗｳｻﾞ
ｳｨﾝﾄﾞｳ
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8 ﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞｳｨﾝﾄﾞｳの EM Structures の下にある "Low Pass Filter"を
ﾀﾞﾌﾞﾙｸﾘｯｸします。

Microwave Office ｳｨﾝﾄﾞｳに EM ﾓﾃﾞﾙ構造の "Low Pass Filter"が表示されま
す。これは、色のついたﾀｲﾄﾙﾊﾞｰで強調表示されていますが、今ｱｸﾃｨﾌﾞ
な状態になっています。

9 Microwave Officeのﾒｲﾝﾒﾆｭｰから View ⇒ New 3D View を選択します。

Microwave Office ｳｨﾝﾄﾞｳに 3次元の EM ﾓﾃﾞﾙ構造体が表示されます。

10 Microwave Officeのﾒｲﾝﾒﾆｭｰから Window ⇒ Tile Vertical を選択します。

このｺﾏﾝﾄﾞは、表示された 4つのｳｨﾝﾄﾞｳをすべて同ｻｲｽﾞにし、また、す
べてのｽﾍﾟｰｽを使用可能にします。  画面は下図のようになっているはずで
す。画面の表示の順番は異なっているかもしれません。 
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11 Microwave Officeのﾒｲﾝﾒﾆｭｰから  File ⇒ Save Project As を選択します。

Save As ﾌﾞﾗｳｻﾞﾞｳｨﾝﾄﾞｳが表示されます。 ﾌﾟﾛｼﾞｪｸﾄをお使いのﾃﾞｨﾚｸﾄﾘに保
存します。 これにより、回路への変更事項が保存され、例題ﾌｧｲﾙを損な
うことを防げます。

Editing in Microwave Office 
Microwave Officeの中で EM 構造を編集するか、または Sonnetの project 
editorの中で編集するか選択できます (AWRの Native Editor )。 Microwave 
Office を使用して構造を編集する時は、 Microwave Officeの環境にいなが
ら、EM ﾓﾃﾞﾙ構造を編集したり、 Microwave Officeで使用可能なｵﾌﾟｼｮﾝを
使用して、 Sonnet の解析ｵﾌﾟｼｮﾝをｺﾝﾄﾛｰﾙします。   Sonnet の解析ｴﾝｼﾞﾝ em
は Microwave Office から起動されます。またその解析結果は Microwave 
Office と、ｵﾌﾟｼｮﾝで Sonnetからも見ることができます。ﾁｭｰﾄﾘｱﾙのこの節
では、 Sonnet Engine Only ﾓｰﾄﾞでの、解析ｴﾝｼﾞﾝとしての Sonnetの選択方
法、 Microwave Officeでの解析の設定方法、解析の実行の方法、そして解
析結果の見方を説明します。

TIP
Microwave Office ﾌﾟﾛｼﾞｪｸﾄではそれぞれの EM ﾓﾃﾞﾙ構造に、Sonnet の解析
ｴﾝｼﾞﾝを選択する必要があります。
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Selecting Sonnet as your EM Analysis Engine

1 以下のように、Microwave Office ｳｨﾝﾄﾞｳのﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞにある、
EM ﾓﾃﾞﾙ構造の "Low Pass Filter"を右ﾎﾞﾀﾝでｸﾘｯｸします。

ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰが表示されます。

EM structure
Low Pass Filter
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2 ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから "Set Simulator"を選択します。

Select a Simulator ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

3 "Sonnet 3D Planar Electromagnetic Simulator" ﾁｪｯｸﾎﾞｯｸｽをｸﾘｯｸします。 

これで、 Microwave Officeで Low Pass Filter構造での解析を実行する時に、
そのｴﾝｼﾞﾝとして Sonnetの電磁界ｼﾐｭﾚｰﾀｴﾝｼﾞﾝである emが設定されま
す。 

OK ﾎﾞﾀﾝをｸﾘｯｸして、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞし、変更事項を適用します。

Selecting Analysis Controls

Sonnet は Sonnet Engine Onlyﾓｰﾄﾞでは、 Microwave Office の環境内での基本
的な解析ｺﾝﾄﾛｰﾙをいくつか用意しています。それらのｺﾝﾄﾛｰﾙを表示した
り設定したりするには、以下のようにします。
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4 以下のように、Microwave Office ｳｨﾝﾄﾞｳのﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞにある、
EM ﾓﾃﾞﾙ構造の "Low Pass Filter" を右ﾎﾞﾀﾝでｸﾘｯｸします。

ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰが表示されます。

5 ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから "Options" を選択します。

General ﾀﾌﾞが選択された Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

EM structure
Low Pass Filter
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6 Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの "Sonnet Options" ﾀﾌﾞをｸﾘｯｸします。

ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが変わり、以下のように表示されるはずです。

帯域全体の ABS ｽｨｰﾌﾟが既にﾃﾞﾌｫﾙﾄで選択されているので、 Sonnetに
ABS ｽｨｰﾌﾟを設定するために何もする必要はありません。

Adaptive Sweep Settings ｺﾝﾄﾛｰﾙは、 S ﾊﾟﾗﾒｰﾀの結果を生成する時に、ﾕｰｻﾞが
adaptiveのﾌﾟﾛｾｽを使用したいかどうかを指定することができます。
Sonnetでは、adaptive の技法を Adaptive Band Synthesis (ABS)と呼びます。
Use Adaptive Band Synthesisを使用不可にすると、解析ｴﾝｼﾞﾝは Microwave 
Officeで指定された各周波数でその回路を解析します。Microwave Office
で 5つ以下の周波数を要求した場合には、これをお勧めします。

しかし、もしMicrowave Officeで 5つかそれ以上の周波数を指定した場
合は、 Use Adaptive Band Synthesisを使用可能にするのが、通常より効果
的です。使用可能時は解析ｴﾝｼﾞﾝは、まず指定された周波数帯域に渡っ
て ABS ｽｨｰﾌﾟを行い、次に adaptiveの結果を使って、 Microwave Office の
各周波数で、S ﾊﾟﾗﾒｰﾀを生成します。これにより、 Microwave Officeの中
で独立した数百、或いは数千の周波数で、非常に細かい周波数能を指定
することができます。また、 adaptiveのﾌﾟﾛｾｽを使用せずに、 5-10 の周波
数を計算するのと同じ時間でこれらの結果を得ることができます。
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Microwave Office ﾌﾟﾛｼﾞｪｸﾄの Global ﾌﾟﾛｼﾞｪｸﾄ解析の周波数は 5 から 35 
GHz を 0.5 GHz 毎です。この場合、 Sonnetではﾃﾞﾌｫﾙﾄの設定になっていま
すが、帯域全体を ABSで行うのが最も効果的です。

7 この実行ｵﾌﾟｼｮﾝを選択するために、Compute Current Density ﾁｪｯｸﾎﾞｯｸｽ
をｸﾘｯｸします。

解析ｴﾝｼﾞﾝ実行中には、電流密度の情報を生成できるようにするために、 
Compute Current Density ｺﾝﾄﾛｰﾙにﾁｪｯｸﾏｰｸを入れます。ﾃﾞﾌｫﾙﾄでは、電流
密度情報は生成されません。このｺﾝﾄﾛｰﾙを使用可能にして、解析ｴﾝｼﾞﾝ
を既に実行していれば、View Currents ﾎﾞﾀﾝがｱｸﾃｨﾌﾞになります。後の
ﾁｭｰﾄﾘｱﾙでこのﾎﾞﾀﾝを使って、Sonnet の Current Density Viewerを起動し
ます。

View Subsections ﾎﾞﾀﾝをｸﾘｯｸして、 Sonnet のｻﾌﾞｾｸｼｮﾝ情報を見ることもで
きます。経験を積んでいるﾕｰｻﾞは解析する前に、この情報を見るのが有
効であるとわかっているので、処理時間と精度に適したｻﾌﾞｾｸｼｮﾝかどう
かを知るのに利用できます。

8 OK ﾎﾞﾀﾝをｸﾘｯｸして、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを閉じ、変更事項を適用します。

Running the Simulation

Microwave Office をｴﾃﾞｨﾀとして選択すると、ｼﾐｭﾚｰｼｮﾝ実行時に、  
Microwave Office は解析ｺﾝﾄﾛｰﾙとEMﾓﾃﾞﾙ構造の図形の情報を  Sonnet に渡
します。 電磁界ｼﾐｭﾚｰｼｮﾝ終了時に Sonnet は要求された解析ﾃﾞｰﾀを出力し
ます。

ｼﾐｭﾚｰｼｮﾝを実行するには次のようにします。
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9 Microwave Officeのﾒｲﾝﾒﾆｭｰから Simulate ⇒ Analyze を選択します。

Sonnetの解析ｴﾝｼﾞﾝ emで実行されてい る電磁界ｼﾐｭﾚｰｼｮﾝの進捗状況を示
すｽﾃｰﾀｽｳｨﾝﾄﾞｳが、以下のように表示されます。お使いのｺﾝﾋﾟｭｰﾀにより
ますが、電磁界の解析は終了までに数分かかります。 

EM ﾓﾃﾞﾙ構造のｼﾐｭﾚｰｼｮﾝが終了すると、ｽﾃｰﾀｽｳｨﾝﾄﾞｳは閉じられます。
Microwave Office ﾌﾟﾛｼﾞｪｸﾄでの完全な回路の解析は非常に速く終了し、
すぐに結果を見ることができます。 Sonnet は ABS ｽｨｰﾌﾟの結果として、
約 300 個のﾃﾞｰﾀ点を生成しながら、 Microwave Officeで要求された 61個
のﾃﾞｰﾀ点しかﾃﾞｰﾀを返さなかったことに、再びご注目ください。

ABS ｽｨｰﾌﾟを行っている間は、em は所望の周波数帯域の初めと終わりで
解析します。次に em はこの過程を繰り返し、他の個別の S ﾊﾟﾗﾒｰﾀの
rational polynomial （多項式）近似を行います。いくつかの特定周波数で
電磁界解析によって得られたﾃﾞｰﾀが、これらの個別ﾃﾞｰﾀです。適切な多
項式が許容誤差内で決定されたら、指定された帯域に渡る周波数の応答
が計算されます。この多項式で生成されたﾃﾞｰﾀが adaptive ﾃﾞｰﾀです。特
にこの ABS ｽｨｰﾌﾟでは、 em は、7つの周波数点で解析を実行しました。 
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SonnetからMicrowave Officeに返された S ﾊﾟﾗﾒｰﾀﾃﾞｰﾀは、Microwave Office
の中でｸﾞﾗﾌ機能を用いて表示することができます。便宜上、例題
ﾌﾟﾛｼﾞｪｸﾄに既にｸﾞﾗﾌが設定されています。

10 もし、Microwave Officeにそのｸﾞﾗﾌがまだ表示されていなかったら、
ﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞの Graph 1 をﾀﾞﾌﾞﾙｸﾘｯｸします。 

以下のようなｸﾞﾗﾌが表示されるはずです。

今回は、Microwave Officeの環境内で Sonnet によって作成された電流密
度ﾃﾞｰﾀを表示することはできません。しかし、Microwave Officeから
Sonnetの Current Density Viewerを起動することはできます。

11 再び、Microwave Office ｳｨﾝﾄﾞｳのﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞの中の "Low Pass 
Filter"をﾏｳｽの右ﾎﾞﾀﾝでｸﾘｯｸします。

ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰが表示されます。

12 ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから "Options" を選択します。

General ﾀﾌﾞが選択された Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

Microwave Office Plot



Sonnet Supplemental Tutorials

84

13 Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの "Sonnet Options" ﾀﾌﾞをｸﾘｯｸします。

以下のようなﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されるはずです。

14 View Currents ﾎﾞﾀﾝをｸﾘｯｸし Sonnetの Current Density Viewerをｵｰﾌﾟﾝします。

Compute Current Density の実行ｵﾌﾟｼｮﾝを有効にして解析を実行していなけれ
ば、このﾎﾞﾀﾝは使用できません。Current density viewer が画面に表示されます。
Current density viewerをｵｰﾌﾟﾝする時には、図形を変更していなかったり、応答
ﾃﾞｰﾀを生成したことによってMicrowave Office がﾛｯｸされていないかご注意く
ださい。 
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15 ひとつ下の金属ﾚﾍﾞﾙを見るために、 Down One Level ﾎﾞﾀﾝをｸﾘｯｸします。

Low Pass Filter.son の Level 1 が、 5 GHzの周波数で表示されます。 

Current density viewer のﾃﾞﾌｫﾙﾄのｱﾆﾒｰｼｮﾝは周波数の関数としてｱﾆﾒｰｼｮﾝ表
示するように設定されているので、ﾓﾃﾞﾙ構造内の電流密度の変化を周波
数の関数として簡単な操作で表示できます。ここでは、実行された全解
析の内で 7つの個別のﾃﾞｰﾀ点のみ、電流密度ﾃﾞｰﾀがあるという点にご注
意いただくことが大切です。 Adaptive ﾃﾞｰﾀは 電流密度ﾃﾞｰﾀを含みません。

TIP
Sonnet の Current Density Viewerの使用方法についての詳細は Sonnet Tuto-
rial と、ｵﾝﾗｲﾝﾍﾙﾌﾟの Current Density Viewerの項目をご覧ください。 

16 Current density viewerのﾒｲﾝﾒﾆｭｰから File ⇒ Exit を選択します。

これで Current density viewerを終了します。 通常の設計のﾌﾟﾛｾｽでは、応
答ﾃﾞｰﾀを見ることによって、 EM ﾓﾃﾞﾙ構造を変更したくなるかもしれませ
ん。もう一度その回路をｼﾐｭﾚｰｼｮﾝする前に、Microwave Officeで EM 
ﾓﾃﾞﾙ構造を編集します。
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次の節では、 Microwave Office Interfaceで native editor を使う方法を説明し
ます。これは、 Sonnet の project editorを使って、 EM ﾓﾃﾞﾙ構造を編集しま
す。

Native Editor
Sonnetのproject editorを native editorに選択した場合には、 Sonnet を電磁界
ｼﾐｭﾚｰｼｮﾝとして用いるだけではなく、EM ﾓﾃﾞﾙ構造のｴﾃﾞｨﾀとしても用い
ます。Native editor は、  Thick Metal、 誘電体ﾌﾞﾘｯｸ、autogrounded ﾎﾟｰﾄなど、 
Sonnetの優位性を示すすべての機能を利用することができます。この
ﾓｰﾄﾞをお使いになるには、ﾕｰｻﾞは Sonnet に精通していなくてはなりませ
んが、 Sonnet の環境に慣れるために Sonnetのﾏﾆｭｱﾙや関連文献もご利用
ください。

このﾁｭｰﾄﾘｱﾙでは、Sonnet で Thick Metal の定義を用いて物理的に厚い金
属を定義します。この回路で物理的に厚い金属を用いるのは、単に説明
のためで、設計上このように決めたわけではありません。この金属ﾓﾃﾞﾙ
はMicrowave Office では使えない機能で、Sonnetの project editor を native 
editorとしての使いかたを説明するために使用します。

ﾁｭｰﾄﾘｱﾙの前の節では、 Sonnetを 電磁界ｼﾐｭﾚｰﾀとして選択しました。ここ
では、  Sonnet をｴﾃﾞｨﾀとして選択します。
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17 Microwave Officeのﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞの中の Low Pass Filterをﾏｳｽの右ﾎﾞﾀﾝ
でｸﾘｯｸし、表示されたﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから "Options" を選択します。

General ﾀﾌﾞの表示された Options ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。

18 Native Editor ﾗｼﾞｵﾎﾞﾀﾝをｸﾘｯｸして、  Sonnet をｴﾃﾞｨﾀとして選択します。
ﾗｼﾞｵﾎﾞﾀﾝの左に、ｼﾐｭﾚｰﾀとして Sonnet が表示されていることにご注目く
ださい。

19 ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽのDocumentの欄のSave Resultsにある  Currents ﾁｪｯｸﾎﾞｯｸｽ
をｸﾘｯｸします。

ﾁｭｰﾄﾘｱﾙの初めの部分のように、解析を実行して EM ﾓﾃﾞﾙ構造の電流密度
ﾃﾞｰﾀを生成します。このﾃﾞｰﾀを将来使うために格納しておくには、 
Microwave Office ﾌﾟﾛｼﾞｪｸﾄの一部として電流密度ﾃﾞｰﾀを保存することを
指定する必要があります。このﾁｪｯｸﾎﾞｯｸｽを選択すると、保存時に
Microwave Office ﾌﾟﾛｼﾞｪｸﾄの中に電流密度ﾃﾞｰﾀを含むことになります。電
流密度ﾃﾞｰﾀを保存すると、ﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙのｻｲｽﾞが非常に大きくなってし
まうことにご注意ください。
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20 OK ﾎﾞﾀﾝをｸﾘｯｸして、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを閉じ、変更事項を適用します。

このｽﾃｯﾌﾟを行うと、 Microwave Officeでは EM ﾓﾃﾞﾙ構造を編集できなく
なります。 Microwave Officeでは EM ﾓﾃﾞﾙ構造を編集しようとすると、以
下のような警告が表示されます。 

次に、Sonnetの project editorを使って回路を編集します。

Editing your EM Structure in Sonnet
21 Microwave Officeのﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞの中の Low Pass Filterをﾏｳｽの右ﾎﾞﾀﾝでｸﾘｯｸ
し、表示されたﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから "Open in Native Editor" を選択します。

Sonnetのproject editor (xgeom)が表示され、そこには 一番上の金属ﾚﾍﾞﾙ0を
示した EM ﾓﾃﾞﾙ構造の Low Pass Filter が表示されます。

22 Project editorのﾂｰﾙﾊﾞｰの Down One Level ﾎﾞﾀﾝをｸﾘｯｸします。

Project editor ｳｨﾝﾄﾞｳに金属ﾚﾍﾞﾙ 1 が表示されます。このﾚﾍﾞﾙ上のすべての金属を
厚い金属に変更しますが、まず金属の種類を定義する必要があります。
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23 Project editorの ﾒｲﾝﾒﾆｭｰから Circuit ⇒ Metal Types を選択します。 

Metal Types ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

24 Add ﾎﾞﾀﾝをｸﾘｯｸし、新しい金属の種類を追加します。

Metal Editor ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

25 Name ﾃｷｽﾄ入力ﾎﾞｯｸｽに "Thick Gold"と入力します。

この金属の種類を選択するためにこの名前が使われます。

26 これがまだ選択されていなければ、Type ﾄﾞﾛｯﾌﾟﾘｽﾄから "Thick Metal 
Model"を選択します。

この種類は物理的に厚い金属をﾓﾃﾞﾙするために使います。他の金属の種
類は厚さｾﾞﾛの金属としてﾓﾃﾞﾘﾝｸﾞざれます。厚い金属のﾓﾃﾞﾘﾝｸﾞについ
ての説明は、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Help ﾎﾞﾀﾝをｸﾘｯｸし、Sonnet User’s Guideの
"Thick Metal"の章をご覧ください。 
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27 Conductivityに “4.09E7” 、 thicknessに “3” と入力します。 

これらのﾊﾟﾗﾒｰﾀは、金属の損失を計算するのに使われます。この例で
は、ﾃﾞﾌｫﾙﾄで 2が適切です。
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すべてのﾊﾟﾗﾒｰﾀを入力したら、 OK ﾎﾞﾀﾝをｸﾘｯｸしてﾀﾞｲﾛｸﾞﾎﾞｯｸｽを閉じ、
変更事項を適用します。今、Metal Types ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽのﾘｽﾄには、 Thick 
Gold が表示されています。

28 Metal Types ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの OK ﾎﾞﾀﾝをｸﾘｯｸして、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを閉じ、
変更事項を適用します。

29 ﾏｳｽでﾚﾍﾞﾙ 1 の金属の図形のまわりをﾄﾞﾗｯｸﾞし、すべての図形を選択しま
す。

選択されたことを示すために、すべての図形が強調表示されています。
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30 Project editorのﾒｲﾝﾒﾆｭｰから Modify ⇒ Metal Properties を選択します。

Metal Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。

31 Metal Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Metal ﾄﾞﾛｯﾌﾟﾘｽﾄから、今定義した金属の
種類の "Thick Gold"をｸﾘｯｸします。

これで、選択されたすべての図形に厚い金属が適用されます。

32 OK ﾎﾞﾀﾝをｸﾘｯｸし、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを閉じて変更事項を適用します。

これらの図形はすべて異なる充填ﾊﾟﾀｰﾝを使っており、Thick Metal の金
属の種類が使われていることがわかります。

33 Project editorのﾂｰﾙﾊﾞｰの Up One Level ﾎﾞﾀﾝをｸﾘｯｸします。

これで、Project editorが回路のﾚﾍﾞﾙ 0を表示します。ここには回路の
ｴｱﾌﾞﾘｯｼﾞがあります。

34 ﾚﾍﾞﾙ 1 で金属の種類を変えたように、このﾚﾍﾞﾙのすべての図形の金属の
種類を "Thick Gold"に変えます。 

回路のすべての金属は今、"Thick Gold"の金属の種類を使っています。
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35 Project editorのﾂｰﾙﾊﾞｰの Save ﾎﾞﾀﾝをｸﾘｯｸし、変更事項を保存します。

Project editorは、ﾌﾟﾛｼﾞｪｸﾄに格納された解析結果を削除するように指示し
てきます。これは図形が変更されたので、そのﾃﾞｰﾀが古くなってしまう
からです。

36 Delete ﾎﾞﾀﾝをｸﾘｯｸして、その矛盾した結果を削除します。

37 Project editorのﾒｲﾝﾒﾆｭｰから File ⇒ Exit を選択します。

Project editor が画面から消え、 Microwave Office が ﾛｯｸ解除されます。 
Microwave Officeで native editor をオープンすると、 Microwave Office の
ﾌﾚｰﾑﾜｰｸは “ ﾛｯｸ ”され、ﾌﾟﾛｼﾞｪｸﾄを変更することも、ｼﾐｭﾚｰｼｮﾝを実行する
こともできません。Project editorがｸﾛｰｽﾞされ、 Microwave Office がﾛｯｸ解
除されると、Microwave Office のﾌﾚｰﾑﾜｰｸで再び変更ができます。
Microwave Office が表示されている時は、以下のようにMicrowave Office
のﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞのMaterials ﾘｽﾄに Thick Metal が含まれていることにご
注目ください。 EM ﾓﾃﾞﾙ構造の充填ﾊﾟﾀｰﾝは Thick Metalを使用しているこ
とを示すために変わっています。 Microwave Officeでは Thick Metal ﾓﾃﾞﾙ

は使えないので、損失の定義は DC 抵抗の Rdc( ｵｰﾑ /sq) と、表皮効果係数 
Rrfを使うMicrowave Officeのﾓﾃﾞﾙに変換されます。 Thick Metal ﾓﾃﾞﾙの定義
は、 Microwave Officeに格納された Sonnet ﾌﾟﾛｼﾞｪｸﾄの一部として保持され
ますが、 表示はされません。

Running the Simulation

構造への変更が終了し、変更事項を保存して Microwave Officeに戻ると、
図形の仕様がMicrowave Officeに送られます。実際には、 Sonnet 
ﾌﾟﾛｼﾞｪｸﾄは、Microwave Office ﾌﾟﾛｼﾞｪｸﾄの一部として格納されます。解
析が実行されると、格納された Sonnet の図形情報が Sonnetに送られ、
電磁界ｼﾐｭﾚｰｼｮﾝが行われ、解析ﾃﾞｰﾀが戻されます。

Thick Gold entry



Sonnet Supplemental Tutorials

94

38 Microwave Officeの中で ﾒｲﾝﾒﾆｭｰから Simulate ⇒ Analyze を選択します。

ｽﾃｰﾀｽｳｨﾝﾄﾞｳが表示され、Sonnetの解析ｴﾝｼﾞﾝ emによって行われている
電磁界ｼﾐｭﾚｰｼｮﾝのﾌﾟﾛｾｽを示します。お使いのｺﾝﾋﾟｭｰﾀによりますが、電
磁界解析が終了するまで数分かかります。ﾁｭｰﾄﾘｱﾙのこの部分の計算時
間は、初めの部分より多くかかります。これは、Sonnetでは厚い金属を
使用するとより多くの計算時間が必要とされるからです。

EM ﾓﾃﾞﾙ構造の電磁界ｼﾐｭﾚｰｼｮﾝが終了すると、ｽﾃｰﾀｽｳｨﾝﾄﾞｳは消えます。 
Microwave Office ﾌﾟﾛｼﾞｪｸﾄのcomplete回路全体の解析は非常に早く終わり
ます。この結果をご覧ください。Sonnet は ABS ｽｨｰﾌﾟの結果として、お
よそ 300個 のﾃﾞｰﾀ点を生成しましたが、 SonnetはMicrowave Officeで要
求された 61個のﾃﾞｰﾀ点にのみ、ﾃﾞｰﾀを返しました。

SonnetからMicrowave Officeに返された S ﾊﾟﾗﾒｰﾀﾃﾞｰﾀは、Microwave Office
の中でｸﾞﾗﾌ機能を用いて表示することができます。便宜上、例題
ﾌﾟﾛｼﾞｪｸﾄに既にｸﾞﾗﾌが設定されています。 以下のようなｸﾞﾗﾌが表示され
るはずです。 Step12から説明されている方法で、 Current Density Viewerで
電流密度ﾃﾞｰﾀを見ることもできます。

回路全体を解析する前に、 EM ﾓﾃﾞﾙ構造だけを設計変更した効果を見たい
のであれば、変更を行った後に Sonnet の中にとどまることができます。 
Sonnet から電磁界解析を実行し、 Sonnetの様々なﾓｼﾞｭｰﾙを使って、その
結果を見てください。その EM ﾓﾃﾞﾙ構造がご自分の仕様に合っていると

Link to this 
spot.
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満足されたら Sonnet を終了し、 Microwave Office の環境に戻ります。回路
全体の解析を実行すると、 Sonnet の解析の結果はすぐに得られるので計
算時間はごく僅かです。

Working Outside Microwave Office
Sonnetの Export と Importの機能を使うと、処理を続けるために  Microwave 
Office をﾛｯｸすることをせずに、 Sonnetで解析を実行できます。しかし、 
Microwave Office の外で作業をすると、Microwave Office ﾌﾟﾛｼﾞｪｸﾄでそのﾃﾞｰﾀ
に一貫性を持たせるために、更にｵｰﾊﾞｰﾍｯﾄﾞ（ｼｽﾃﾑの負荷）が必要となります。
ﾁｭｰﾄﾘｱﾙのこの節では、解析全体でMicrowave Officeをﾛｯｸせずに Sonnetで EM 
ﾓﾃﾞﾙ構造を解析する方法、EM ﾓﾃﾞﾙ構造を Microwave Office から Sonnet ﾌﾟﾛｼﾞｪｸﾄ
へｴｸｽﾎﾟｰﾄする方法、そして Sonnet ﾌﾟﾛｼﾞｪｸﾄを EM ﾓﾃﾞﾙ構造としてｲﾝﾎﾟｰﾄする方
法を説明します。

39 Microwave Officeの中で lowpass.empをまだｵｰﾌﾟﾝしてなければ、ｵｰﾌﾟﾝします。

40 Microwave Officeのﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞの中のLow Pass FilterのEMﾓﾃﾞﾙ構造をﾏｳｽの
右ﾎﾞﾀﾝでｸﾘｯｸし、表示されたﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから "Open in Native Editor" を選択
します。

Sonnetの project editorの中で この EM ﾓﾃﾞﾙ構造が表示されます。

通常は、回路をもう一度解析する前に、EM ﾓﾃﾞﾙ構造を変更するでしょう。ここ
では、 Export と Import の機能を説明したいだけなので、この回路には何も変更
を加えません。

Sonnetの中で EM ﾓﾃﾞﾙ構造をｵｰﾌﾟﾝすると、Microwave Office で設定された解
析ｺﾝﾄﾛｰﾙは、  Sonnetへ送られる図形の一部として伝えられます。解析したい回
路は、かなり解析時間がかかることがわかっています。従って、Microwave 
Officeをﾛｯｸせずに、解析の処理時間をそっくり EM ﾓﾃﾞﾙ構造の解析に当てたく
なります。これを行うには次のようにします。
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41 Project editorのﾒｲﾝﾒﾆｭｰから File ⇒ MWOffice ⇒ Analyze Outside 
MWOffice を選択します。

ｺﾏﾝﾄﾞを説明したｳｨﾝﾄﾞｳが表示されます。 Analyze Outside MWOffice は、 Microwave 
Office ﾌﾟﾛｼﾞｪｸﾄをｴｸｽﾎﾟｰﾄする際の解析周波数ｺﾝﾄﾛｰﾙを備えています。すぐに解
析を実行したくない時や、 Sonnet の環境だけで、回路上で作業したい場合は、
File ⇒ MWOffice ⇒ Save as Sonnet Project ｺﾏﾝﾄﾞを使って、 EM ﾓﾃﾞﾙ構造を  Sonnet 
ﾌﾟﾛｼﾞｪｸﾄへｴｸｽﾎﾟｰﾄします。 

TIP
このｺﾏﾝﾄﾞを選択するたびに、ﾒｯｾｰｼﾞ表示させたくない場合は、Don’t show me 
this again ﾁｪｯｸﾎﾞｯｸｽにﾁｪｯｸﾏｰｸを入れます。後でこのﾒｯｾｰｼﾞを元に戻したい場合
は、 Preferences ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Hints ﾀﾌﾞの中で、そのように指定します。  Prefer-
ences ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽは project editor のﾒｲﾝﾒﾆｭｰから  File ⇒ Preferences を選択する
と表示されます。

42 ﾒｯｾｰｼﾞを読んだら、 OK ﾎﾞﾀﾝをｸﾘｯｸしてﾒｯｾｰｼﾞﾎﾞｯｸｽを閉じます。

ﾒｯｾｰｼﾞﾎﾞｯｸｽが消えて、 ﾌﾞﾗｳｻﾞｳｨﾝﾄﾞｳが表示されます。

Microwave Officeをﾛｯｸしないためには、EM ﾓﾃﾞﾙ構造を Sonnet ﾌﾟﾛｼﾞｪｸﾄの一時的
な場所に保存する必要があります。このｳｨﾝﾄﾞｳで、Sonnet ﾌﾟﾛｼﾞｪｸﾄの場所を指定
することができます。
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43 ﾌﾞﾗｳｻﾞ ｳｨﾝﾄﾞｳで、保存場所に  c:\MWOffice_tutorial.son と入力し、 OK 
ﾎﾞﾀﾝをｸﾘｯｸします。

ご希望であれば、お使いのｺﾝﾋﾟｭｰﾀの別の保存場所を選ぶことができま
す。 ﾌﾞﾗｳｻﾞ ｳｨﾝﾄﾞｳが閉じると、解析ﾓﾆﾀｰが表示され、解析が始まったこ
とを示します。解析ﾓﾆﾀｰのﾀｲﾄﾙﾊﾞｰに表示されたﾌｧｲﾙ名は、  
"MWOffice_tutorial.son"となっていることにご注目ください。

44 Project editor のﾒｲﾝﾒﾆｭｰから File ⇒ Exit を選択します。

Project editor が閉じられ、  Microwave Office が再び画面に表示されます。 
Microwave Office はﾛｯｸが解除され、使用可能となります。Project editor 
が閉じられると、 EM ﾓﾃﾞﾙ構造は Microwave Officeに戻されます。Sonnet 
で解析が実行されている間は、Microwave Officeでの EM ﾓﾃﾞﾙ構造への
変更ができないように、このﾓｰﾄﾞを使用する時は、Sonnetを Native 
Editor として選択することが重要です。これにより、この図形は解析
ﾃﾞｰﾀと合わなくなるでしょう。 

45 Sonnetでの解析が終了するまで待ちます。

通常、これにはかなりの時間がかかりますが、ここでは EM ﾓﾃﾞﾙ構造に
は何も変更を行っていないので、この解析は前のｼﾐｭﾚｰｼｮﾝからのﾃﾞｰﾀを
使うことができ、このｼﾞｮﾌﾞは非常に早く終了します。
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ここで、 Microwave Officeでその解析結果を使えるようにするために、一
時的な Sonnet ﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙをｲﾝﾎﾟｰﾄする必要があります。

46 Microwave Officeのﾌﾟﾛｼﾞｪｸﾄﾌﾞﾗｳｻﾞの中のEMﾓﾃﾞﾙ構造の Low Pass Filter
をﾏｳｽの右ﾎﾞﾀﾝでｸﾘｯｸし、表示されたﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから "Open in Native 
Editor" を選択します。

EM ﾓﾃﾞﾙ構造が project editorに表示されます。 これを解析の終了したばか
りの Sonnet ﾌﾟﾛｼﾞｪｸﾄと入れ替えます。

47 Project editorのﾒｲﾝﾒﾆｭｰから File ⇒ MWOffice ⇒ Load Sonnet Project を
選択します。

EM ﾓﾃﾞﾙ構造を上書きすることになるとの警告ﾒｯｾｰｼﾞが表示されます。 

48 Continue ﾎﾞﾀﾝをｸﾘｯｸします。

ﾒｯｾｰｼﾞｳｨﾝﾄﾞｳが閉じて、ﾌﾞﾗｳｻﾞ ｳｨﾝﾄﾞｳが表示され、このｳｨﾝﾄﾞｳでﾛｰﾄﾞし
たい Sonnet ﾌﾟﾛｼﾞｪｸﾄを選択することができます。

49 ﾌﾞﾗｳｻﾞｳｨﾝﾄﾞｳの "c:\mwoffice_tutorial.son" を選択します。

これは step 43で 、Analyze Outside MWOffice ｺﾏﾝﾄﾞを 実行した時に  EM 
ﾓﾃﾞﾙ構造を保存した一時的なﾌｧｲﾙです。このｺﾏﾝﾄﾞは解析結果とともに、 
Microwave Officeをｵｰﾌﾟﾝした EM ﾓﾃﾞﾙ構造の中にﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙをﾛｰﾄﾞし
ます。 

50 Project editor のﾒｲﾝﾒﾆｭｰから  File ⇒ Exit を選択します。

Project editorが閉じ、今ﾛｰﾄﾞした  Sonnet ﾌﾟﾛｼﾞｪｸﾄが EM ﾓﾃﾞﾙ構造のため
に、 Microwave Office にｲﾝﾎﾟｰﾄ されます。Microwave Office のﾛｯｸは解除さ
れ、画面に再び表示されます。 
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51 Microwave Officeのﾒｲﾝﾒﾆｭｰから Simulate ⇒ Analyze を選択します。

Low Pass Filter の結果は、既に計算されているので、解析は非常に早く終
了します。 ｸﾞﾗﾌが更新されます。 EM ﾓﾃﾞﾙ構造は変更されていないので、
これは 95 ﾍﾟｰｼﾞのｸﾞﾗﾌと同じはずです。これで Microwave Office Interface 
のﾁｭｰﾄﾘｱﾙを終わります。




