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Chapter 2 Parameter Sweep and 
Optimization Tutorial

このﾁｭｰﾄﾘｱﾙでは回路でのﾊﾟﾗﾒｰﾀの設定方法、 ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟの設定及び実
行方法、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの設定及び実行方法そしてﾊﾟﾗﾒｰﾀｽｨｰﾌﾟとｵﾌﾟﾃｨ 
ﾏｲｾﾞｰｼｮﾝの結果の表示方法を述べます。 ﾊﾟﾗﾒﾀﾗｲｾﾞｰｼｮﾝ及びｵﾌﾟﾃｨﾏｲｾﾞｰ 
ｼｮﾝについての詳細は Sonnet User’s Guideの 155 ﾍﾟｰｼﾞの第 10章
“Parameterization and Optimization of a Geometry project” をご覧ください。

このﾁｭｰﾄﾘｱﾙは ﾕｰｻﾞが Sonnet ﾌﾟﾛｸﾞﾗﾑ、特に project editorと解析ﾓﾆﾀｰを使
い慣れているものと仮定しています。もし Sonnetを使うのが初めてであ
れば、このﾁｭｰﾄﾘｱﾙを行なう前に Sonnet Tutorialの第 2章と第 3章にあ
るﾁｭｰﾄﾘｱﾙを行なってください。 

この例題は、 Sonnet 例題ﾌｧｲﾙ Par_dstub を使います。 Sonnet の例題ﾌｧｲﾙの
入手方法については、いずれかのﾌﾟﾛｸﾞﾗﾑﾒﾆｭｰから Help ⇒ Examples を選
択し、続いて Instructions ﾎﾞﾀﾝをｸﾘｯｸします。
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TIP
PDF ﾏﾆｭｱﾙを使ってこの節をお読みになっている方は、上の青色のﾘﾝｸを
ｸﾘｯｸすると、 Par_dstub の例題に入れます。

これはﾏｲｸﾛｽﾛﾘｯﾌﾟのｲﾝﾀｰﾃﾞｨｼﾞﾀﾙﾊﾞﾝﾄﾞﾊﾟｽﾌｨﾙﾀｰの例題です。この回路はﾊﾟﾗﾒｰﾀ 
ｽｨｰﾌﾟとｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを実行するのに利用されます。ほとんどのﾊﾟﾗﾒｰﾀｽｨｰﾌﾟと
ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝには、更に難しい問題もありますが、ここでは、意図的にｼﾝﾌﾟﾙな
例題を選び、 Sonnetの方法論をよりわかりやすく説明しています。

ｺﾞｰﾙはﾊﾟｽﾊﾞﾝﾄﾞが 5 - 6  GHzで、ｽﾄｯﾌﾟﾊﾞﾝﾄﾞが 1 - 4  GHz と 7-10 GHzであ
るようなﾊﾞﾝﾄﾞﾊﾟｽﾌｨﾙﾀｰを設計することです。

1 Project editorで Par_dstubをｵｰﾌﾟﾝします。

2 Project editorのﾒｲﾝﾒﾆｭｰから File ⇒ Save As を選択します。

このﾌｧｲﾙは  Sonnet の例題なので、読み込み専用のﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙです。回
路を修正し、その変更内容を保存できるようにするためには、そのﾌｧｲﾙ
のｺﾋﾟｰをお使いのﾜｰｷﾝｸﾞﾃﾞｨﾚｸﾄﾘに保存する必要があります。

Save As browse ｳｨﾝﾄﾞｳを使って、 par_dstub.son のｺﾋﾟｰをお使いのﾜｰｷﾝｸﾞ 
ﾃﾞｨﾚｸﾄﾘに保存します。

Setting Up Parameters
ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟまたはｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを実行する前に、まず回路をﾊﾟﾗﾒﾀﾗｲｽﾞする必
要があります。ﾊﾟﾗﾒﾀﾗｲｾﾞｰｼｮﾝは回路の応答に対してｸﾘﾃｨｶﾙであるとﾕｰｻﾞが判断
する寸法、すなわち設計が進行するに従って、より変化するものに対して行われ
るべきです。

この例題では、3つのﾊﾟﾗﾒｰﾀを入力します。ﾘﾝｸされた 2つの  anchored ﾊﾟﾗﾒｰﾀと、
１つの symmetric ﾊﾟﾗﾒｰﾀです。
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Anchored ﾊﾟﾗﾒｰﾀは、ﾊﾟﾗﾒｰﾀの片端を固定ﾎﾟｲﾝﾄ（ｱﾝｶｰ ) とし、その点を基
準にして動く点を持つﾊﾟﾗﾒｰﾀです。Symmetric ﾊﾟﾗﾒｰﾀは、2つの参照点が
あるﾊﾟﾗﾒｰﾀで、2つの点はその参照ﾎﾟｲﾝﾄの間の中心点を基準にして動き
ます。 

回路の中で１つ以上の場所に現れるﾊﾟﾗﾒｰﾀで、長さと名前が同じものはﾘﾝｸされ
ます。片方の値を変えると、もう片方の値も変わります。

ﾊﾟﾗﾒｰﾀとその定義については Sonnet User’s Guideの 156 ﾍﾟｰｼﾞの
“Parameters”をご覧ください。 

Anchored Parameters 

ﾘﾝｸされた anchored ﾊﾟﾗﾒｰﾀを最初に入力し、次に symmetric ﾊﾟﾗﾒｰﾀが続きます。

3 Project editorのﾒｲﾝﾒﾆｭｰから Tools ⇒ Add Parameter ⇒ Add Anchored を
選択します。 

これで project editor は Add an Anchored Parameter ﾓｰﾄﾞに入りますが、それはｶ - ｿﾙ
が変化するのでわかります。“Click Mouse to Specify the Anchor Point”という
ﾒｯｾｰｼﾞが project editor ｳｨﾝﾄﾞｳの下のｽﾃｰﾀｽﾊﾞｰに 表示されることに注目してくださ
い。１つのﾊﾟﾗﾒｰﾀを追加していくと、各ｽﾃｯﾌﾟの指示がｽﾃｰﾀｽﾊﾞｰに表示されます。

4 ﾊﾟﾗﾒｰﾀに Anchor ﾎﾟｲﾝﾄを指定するために、以下のように上のｽﾀﾌﾞの角を 
ｸﾘｯｸします。

Anchor ﾎﾟｲﾝﾄは小さな四角で表示され、ｸﾘｯｸした点のところに現れます。
次のｽﾃｯﾌﾟでは、参照ﾎﾟｲﾝﾄを選びます。

Anchor ﾎﾟｲﾝﾄ
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TIP
Anchor ﾎﾟｲﾝﾄまたは参照ﾎﾟｲﾝﾄに間違った点を選んでしまった場合は、
ｴｽｹｰﾌﾟｷｰを押すと、ﾊﾟﾗﾒｰﾀの追加が行われません。この後で初めからや
り直すことができます。

5 一番上のｽﾀﾌﾞの左上端をｸﾘｯｸして参照ﾎﾟｲﾝﾄを追加します。

参照ﾎﾟｲﾝﾄは小さな四角で表示され、ｸﾘｯｸした点のところに現れます。

次のｽﾃｯﾌﾟでは、残りの調整可能なﾎﾟｲﾝﾄｾｯﾄを選びます。点は１つ１つ
の点をｸﾘｯｸしても、またはﾏｳｽで一組の点をﾗｯｿ ( なげ縄ﾂｰﾙ）しても選ぶ
ことができます。参照ﾎﾟｲﾝﾄは自動的に調整可能なﾎﾟｲﾝﾄｾｯﾄの中に含ま
れるので選ぶ必要はありません。

6 ｽﾀﾌﾞの端部の両方の点が選ばれるまでﾏｳｽをﾄﾞﾗｯｸﾞします。

これらの点は調整可能なﾎﾟｲﾝﾄｾｯﾄに追加されます。ﾊﾟﾗﾒｰﾀ値の変化に
従って参照ﾎﾟｲﾝﾄが動くとこれらの点は参照ﾎﾟｲﾝﾄに関連して動きます。

参照ﾎﾟｲﾝﾄ

Selected Points
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7 所望するすべての点をｾﾚｸﾄしたら、 Enter ｷｰを押します。

これでﾊﾟﾗﾒｰﾀの作成は終了です。 Parameter Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面
に表示されます。

8 Parameter Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽのName入力ﾎﾞｯｸｽの中に“Lstub”とい
う名前を入力し、OK ﾎﾞﾀﾝをｸﾘｯｸします。

これでﾊﾟﾗﾒｰﾀに名前がつけられます。OK ﾎﾞﾀﾝをｸﾘｯｸすると、長さと名
前を示した矢印が画面に表示されます。

9 ｽﾀﾌﾞの上に名前が載るまでﾏｳｽを動かします。 名前が置きたい場所に来た
ら、ﾏｳｽをｸﾘｯｸします。

下図のようなﾊﾟﾗﾒｰﾀが現れます。

次にﾘﾝｸされたﾊﾟﾗﾒｰﾀを入力します。ﾘﾝｸされたﾊﾟﾗﾒｰﾀは、同じ名目値と
名前を持った回路の中に確認されたもう１つのﾊﾟﾗﾒｰﾀです。

10 Project editorのﾒｲﾝﾒﾆｭｰから Tools ⇒ Add Parameter ⇒ Add Anchored を
選択します。 

これで project editorが  Add an Anchored Parameter ﾓｰﾄﾞになります。この
ことは、ｶｰｿﾙが変わることでわかります。 

Name text
entry box



Sonnet Supplemental Tutorials

16

11 ﾊﾟﾗﾒｰﾀに Anchor ﾎﾟｲﾝﾄを設定する ために、以下に示すように下のｽﾀﾌﾞの
角をｸﾘｯｸします。

Anchor ﾎﾟｲﾝﾄは小さな小さな四角で表示され、ｸﾘｯｸした点のところに現れま
す。次のｽﾃｯﾌﾟでは参照ﾎﾟｲﾝﾄを選びます。

12 下のｽﾀﾌﾞの右の端部をｸﾘｯｸし、参照ﾎﾟｲﾝﾄを追加します。

参照ﾎﾟｲﾝﾄは小さな四角で表示され、ｸﾘｯｸした点のところに現れます。 

次のｽﾃｯﾌﾟでは、残りの調整可能なﾎﾟｲﾝﾄｾｯﾄを選びます。点は project 
editorで使えるｴﾃﾞｨｯﾄｺﾏﾝﾄﾞのどれかを使用して選ぶことができます。

Anchor ﾎﾟｲﾝﾄ

参照ﾎﾟｲﾝﾄ
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13 ｽﾀﾌﾞの端部の両方の点が 選ばれるまでﾏｳｽをﾄﾞﾗｯｸﾞします。

これらの点は、調整可能なﾎﾟｲﾝﾄｾｯﾄに追加されます。これらの点は参照
ﾎﾟｲﾝﾄが動くと、参照ﾎﾟｲﾝﾄに関連して動きます。

14 所望するすべての点を選んだら、 Enter ｷｰを押します。

これでﾊﾟﾗﾒｰﾀの作成は終了です。 Parameter Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面
に表示されます。

15 Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Name 入力ﾎﾞｯｸｽの中に “Lstub” という名前を
入力し、  OK ﾎﾞﾀﾝをｸﾘｯｸします。

これでﾊﾟﾗﾒｰﾀに名前がつけられます。OK ﾎﾞﾀﾝをｸﾘｯｸすると、長さと名
前を示した矢印が画面に表示されます。 ﾏｳｽを使って所望する位置まで
ﾗﾍﾞﾙを移動し、ｸﾘｯｸします。

このﾊﾟﾗﾒｰﾀの名目値はﾕｰｻﾞが定義した１つめのﾊﾟﾗﾒｰﾀと同じなので
project editor では同じ名前を使えます。これらのﾊﾟﾗﾒｰﾀは今、ﾘﾝｸされて
います。ﾊﾟﾗﾒｰﾀの１つの値が変更されると、両方の値が変わります。
ﾊﾟﾗﾒｰﾀが異なる長さであった場合には、ﾕｰｻﾞが同じ名前を使おうとした
時に、ｴﾗｰﾒｯｾｰｼﾞが出たはずです。

次に最後の symmetric ﾊﾟﾗﾒｰﾀを定義します。

Selected Points
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Symmetric Parameters

16 Project editorのﾒｲﾝﾒﾆｭｰから Tools ⇒ Add Parameter ⇒ Add Symmetric を
選択します。 

これで project editor は Add a Symmetric Parameter ﾓｰﾄﾞになります。このこ
とは、ｶｰｿﾙが変わることでわかります。Project editor ｳｨﾝﾄﾞｳの下の
ｽﾃｰﾀｽﾊﾞｰに “Click mouse to specify first reference point”というﾒｯｾｰｼﾞが表示
されることに注目してください。ﾊﾟﾗﾒｰﾀを追加すると、各ｽﾃｯﾌﾟの方向
がｽﾃｰﾀｽﾊﾞｰに表示されます。

17 ﾊﾟﾗﾒｰﾀに１つめの参照ﾎﾟｲﾝﾄを設定するために、以下に示すように一番
上のｽﾀﾌﾞの内側と伝送線路の交わる地点をｸﾘｯｸします。

１つめの参照ﾎﾟｲﾝﾄは、小さな四角で表示され、ｸﾘｯｸした点のところに
現れます。次のｽﾃｯﾌﾟでは、１つめの参照ﾎﾟｲﾝﾄに置きたいﾎﾟｲﾝﾄｾｯﾄを選
びます。 

１つめの参照ﾎﾟｲﾝﾄ
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18 上のｽﾀﾌﾞのすべての点が選ばれるまでﾏｳｽをﾄﾞﾗｯｸﾞします。

これらの点は１つめの調整可能なﾎﾟｲﾝﾄｾｯﾄに追加されます。１つめの参
照ﾎﾟｲﾝﾄが動くと、これらの点は、参照ﾎﾟｲﾝﾄと同じ方向と距離で動きま
す。

19 所望する点がすべて選ばれたら Enter ｷｰを押します。

これで１つめのﾎﾟｲﾝﾄｾｯﾄができました。回路は下のようになっているは
ずです。

Project editor ｳｨﾝﾄﾞｳの下のｽﾃｰﾀｽﾊﾞｰに “Click Mouse to Specify Second 
Reference Point”というﾒｯｾｰｼﾞが表示されます。次に 2つめの参照ﾎﾟｲﾝﾄと
そのﾎﾟｲﾝﾄｾｯﾄを設定します。

Selected Points

１つめのﾎﾟｲﾝﾄｾｯﾄはｾｯﾄの
すべての点の上に小さな
白い四角で 表示されます。
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20 ﾊﾟﾗﾒｰﾀに 2つめの参照ﾎﾟｲﾝﾄを設定するために、以下に示すように一番下
のｽﾀﾌﾞの内側と伝送線路の交わる地点をｸﾘｯｸします。

2つめの参照ﾎﾟｲﾝﾄは、小さな四角で表示され、ｸﾘｯｸした点のところに現
れます。１つめのﾎﾟｲﾝﾄｾｯﾄは、すべての点の上に依然として小さな四角
で表示されていることに注目してください。次のｽﾃｯﾌﾟでは、2つめの参
照ﾎﾟｲﾝﾄに置きたいﾎﾟｲﾝﾄｾｯﾄを選びます。 

21 下のｽﾀﾌﾞのすべての点が選ばれるまでﾏｳｽをﾄﾞﾗｯｸﾞします。

これらの点は 2つめの調整可能なﾎﾟｲﾝﾄｾｯﾄに追加されます。2つめの参
照ﾎﾟｲﾝﾄが動くと、これらの点は、参照ﾎﾟｲﾝﾄと同じ方向と距離で動きま
す。

22 所望する点がすべて選ばれたら Enter ｷｰを押します。

これで 2つめのﾎﾟｲﾝﾄｾｯﾄと symmetric ﾊﾟﾗﾒｰﾀが完成しました。 Parameter 
Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。 

2つめの
参照ﾎﾟｲﾝﾄ

Selected Points
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23 Parameter Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Name 入力ﾎﾞｯｸｽの中に “Sstub” と
いう名前を入力し、  OK ﾎﾞﾀﾝをｸﾘｯｸします。

これでﾊﾟﾗﾒｰﾀに名前がつけられます。OK ﾎﾞﾀﾝをｸﾘｯｸすると、長さと名
前を示した矢印が画面に表示されます。参照ﾎﾟｲﾝﾄの間には x ( 水平 )方
向と y( 垂直 ) 方向ともに距離がとれるので、ﾊﾟﾗﾒｰﾀを x 方向または y 方
向のどちらか一方で定義するには、ﾊﾟﾗﾒｰﾀ名をうまく移動させる必要が
あるかもしれません。

Y方向を選ぼうとしてﾊﾟﾗﾒｰﾀの定義で、両方の参照ﾎﾟｲﾝﾄの左または右に
ﾏｳｽを動かすと、以下のようになるでしょう。

しかし、この例題ではﾏｳｽを両方の参照ﾎﾟｲﾝﾄの上や下、或いは上方、下
方に動かして、 x 方向にﾊﾟﾗﾒｰﾀを定義しています。

24 ｽﾙｰﾗｲﾝのまん中に名前がくるまでﾏｳｽを動かします。 置きたい場所に名前
がきたら、ﾏｳｽをｸﾘｯｸします。

これでﾊﾟﾗﾒｰﾀを x 方向に設定します。ﾊﾟﾗﾒｰﾀは今、以下のようになって
いるはずです。
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これでﾊﾟﾗﾒｰﾀの入力は終了です。 Lstubは Sstubに影響されるということ
に注目してください。Sstub が増えると、それは直接には Lstubの値には
影響しませんが、 2つのｽﾀﾌﾞは遠く離れます。Lstub は Sstubに依存して
います。 

25 Project editorのﾒｲﾝﾒﾆｭｰから File ⇒ Save を選択します。

これで、解析できるように回路を修正した内容が保存されます。 

ﾁｭｰﾄﾘｱﾙの次の節では回路上でのﾊﾟﾗﾒｰﾀｽｨｰﾌﾟの設定と実行方法を 説明し
ます。

Parameter Sweep 
ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟは Lstubの変数だけを使用します。 2.0 GHz から 10.0 GHzの
周波数帯で、 Lstubの 2つの異なる長さの回路を解析します。このｽｨｰﾌﾟ
が完了すると、response viewerでﾚｽﾎﾟﾝｽｶｰﾌﾞが表示されます。

ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟについての詳細は、 Sonnet User’s Guideの 164 ﾍﾟｰｼﾞの 
“Parameter Sweep”をご覧ください。

Setting Up a Parameter Sweep

1 Project editorのﾒｲﾝﾒﾆｭｰから Analysis ⇒ Setup を選択します。

Analysis Setup ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。
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2 Analysis Control ﾄﾞﾛｯﾌﾟﾘｽﾄから Parameter Sweepを選択します。 

これでﾊﾟﾗﾒｰﾀｽｨｰﾌﾟが解析の種類として選ばれます。ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟに必要な入力が
できるようにﾀﾞｲｱﾛｸﾞの表示が変わります。 Compute Current Density 実行 ｵﾌﾟｼｮﾝは
ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟでは使用できないことに注意してください。

3 ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Analysis Control 欄の Add ﾎﾞﾀﾝをｸﾘｯｸします。

Parameter Sweep Entry ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。このﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽ
からﾊﾟﾗﾒｰﾀｽｨｰﾌﾟを追加することができます。 

最初のｽﾃｯﾌﾟは、ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟに用いたい解析周波数を設定することで
す。 この例題では、 2.0 GHzから 10.0 GHzまで ABS ｽｨｰﾌﾟを実行します。 
Adaptive ｽｨｰﾌﾟ (ABS)はﾃﾞﾌｫﾙﾄのｽｨｰﾌﾟﾀｲﾌﾟなので、これを選択するため
に何もする必要はありません。 

4 Parameter Sweep entry ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽのFrequency Specification欄の Start 
入力ﾎﾞｯｸｽに 2.0 と入力します。

これは開始の周波数です。

Analysis Control
drop list



Sonnet Supplemental Tutorials

24

5 Stop ﾃｷｽﾄ入力ﾎﾞｯｸｽに 10.0 と入力します。

これは最高周波数です。 これで、2 GHz から 10 GHzの帯域で 
adaptive ｽｨｰﾌﾟすることになります。 

次にｽｨｰﾌﾟしたいﾊﾟﾗﾒｰﾀを選びます。 

6 Lstubのﾊﾟﾗﾒｰﾀの入力ﾎﾞｯｸｽのある Sweep欄のﾁｪｯｸﾎﾞｯｸｽをｸﾘｯｸします 。

１つのﾊﾟﾗﾒｰﾀｽｨｰﾌﾟのために複数のﾊﾟﾗﾒｰﾀを選ぶことが可能です。しか
し、この例題では、ﾊﾟﾗﾒｰﾀは１つだけ使用します。そのﾊﾟﾗﾒｰﾀを選びた
くないのであれば、ﾁｪｯｸﾎﾞｯｸｽをもう一度ｸﾘｯｸするだけです。ﾁｪｯｸされ
なかったﾊﾟﾗﾒｰﾀは、名目値でｼﾐｭﾚｰﾄされます。つまり、 Sstubは定数で、
このﾊﾟﾗﾒｰﾀｽｨｰﾌﾟでは 220 milに固定されています。
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回路の現在のﾊﾟﾗﾒｰﾀ値である名目値が、ﾊﾟﾗﾒｰﾀ入力ﾎﾞｯｸｽの Nom欄に表
示されます。この場合では、Lstubの名目値は 220 milです。従って、 
project editorは、ﾊﾟﾗﾒｰﾀの開始値が異なっていてもその長さを 220 milと
表示します。 

7 Lstub の列の Start ﾃｷｽﾄ入力ﾎﾞｯｸｽに 120と入力します。

Lstubで使用される１つめのﾊﾟﾗﾒｰﾀ値として 120 milが設定されます。

8 Lstub の列の Stop ﾃｷｽﾄ入力ﾎﾞｯｸｽに 280と入力します。

Lstub で使用される最後のﾊﾟﾗﾒｰﾀ値として 280 milが設定されます。

9 Lstub の列の Step ﾃｷｽﾄ入力ﾎﾞｯｸｽに 160と入力します。

ﾊﾟﾗﾒｰﾀの間隔が  160 milに設定されます。従って、ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟは 120 mil
と 280milの 2つのﾊﾟﾗﾒｰﾀ値で解析します。start、top、stept の 3つの
ﾌｨｰﾙﾄﾞがすべて要求されることに注目することが重要です。

これでﾊﾟﾗﾒｰﾀｽｨｰﾌﾟの入力の設定は終了です。

10 OK ﾎﾞﾀﾝをｸﾘｯｸしてﾀﾞｲｱﾛｸﾞをｸﾛｰｽﾞします。

ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽがｸﾛｰｽﾞされると、定義されたばかりのﾊﾟﾗﾒｰﾀｽｨｰﾌﾟの入力
内容で Analysis Setup ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが更新されます。この場合は、単独の
ﾊﾟﾗﾒｰﾀに 2つの値があるので、2つのﾊﾟﾗﾒｰﾀの組み合わせがあります。
各々の組み合わせは各々の解析周波数で解析されます。
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2つのﾊﾟﾗﾒｰﾀがある場合、例えば、１つめのﾊﾟﾗﾒｰﾀに 7つの値があり、2つめの
ﾊﾟﾗﾒｰﾀに 11の値があるとすると、解析には 77の組み合わせのﾊﾟﾗﾒｰﾀがあること
になります。

11 OK ﾎﾞﾀﾝをｸﾘｯｸして、  Analysis Setup ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞします。

これでﾊﾟﾗﾒｰﾀｽｨｰﾌﾟの入力は終了です。 

次にこの解析を実行し、その過程を観察するために解析ﾓﾆﾀｰを使います。

Executing the Parameter Sweep

12 Project editorのﾒｲﾝﾒﾆｭｰから  Project ⇒ Analyzeを選択して解析ｴﾝｼﾞﾝ em
を起動し、解析を開始します。

保存するように指示が表示されたら、ﾌｧｲﾙを保存してください。解析
ﾓﾆﾀｰの出力 ｳｨﾝﾄﾞｳが画面に表示されます。 
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13 解析ﾓﾆﾀｰの 出力 ｳｨﾝﾄﾞｳの Response Data ﾎﾞﾀﾝをｸﾘｯｸします。

これで解析が進行する様子を観察できます。ｳｨﾝﾄﾞｳの一番上にﾌﾟﾛｸﾞﾚｽﾊﾞｰがあ
り、そこには全解析の何ﾊﾟｰｾﾝﾄが完了したかが表示されます。 応答ﾃﾞｰﾀがｳｨﾝﾄﾞｳ
の下に表示されます。

お使いのｺﾝﾋﾟｭｰﾀによっては、解析の実行には数分かかるかもしれません。

解析が完了したら、 response viewerをｵｰﾌﾟﾝして解析結果を見てください。

Observing the Parameter Sweep Data

Lstub = 120 milと Lstub = 280 milの S21 の応答ﾃﾞｰﾀを見ることにします。

14 解析ﾓﾆﾀｰの出力ｳｨﾝﾄﾞｳのﾒｲﾝﾒﾆｭｰから Project ⇒ View Response ⇒ New Graph
を選択します。

S11が表示された response viewer が画面に表示されます。 

15 Curve Group legend( ｸﾞﾗﾌの左側のｷｬﾌﾟｼｮﾝ )の par_dstub をﾏｳｽの右ﾎﾞﾀﾝでｸﾘｯｸし
ます。

ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰが表示されます。

16 ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから Edit Curve Groupを選択します。

Edit Curve Group ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。

17 Selected ﾘｽﾄの DB[S11] をﾀﾞﾌﾞﾙｸﾘｯｸします。

S11 の応答が Unselected ﾘｽﾄへ移動されます。これでﾌﾟﾛｯﾄ上にはもう表示されま
せん。

18 Unselected ﾘｽﾄの DB[S21] をﾀﾞﾌﾞﾙｸﾘｯｸします。

S21 の応答が Selected ﾘｽﾄへ移動され、ﾌﾟﾛｯﾄ上に表示されます。

19 Edit CurveGroup ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Select Combinations ﾎﾞﾀﾝをｸﾘｯｸします。

Select Parameters ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。
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20 Selected Parameters ﾘｽﾄの上の Select All ﾎﾞﾀﾝをｸﾘｯｸします。

このﾘｽﾄにはたった１つのｴﾝﾄﾘｰしかないはずです。 Select All ﾎﾞﾀﾝは、この機能を
説明するために使用されました。これで Selected ﾘｽﾄのすべてのﾊﾟﾗﾒｰﾀが選択さ
れました。 

21 Up Arrow ﾎﾞﾀﾝをｸﾘｯｸして、すべてのﾊﾟﾗﾒｰﾀの組み合わせを Unselected 
ﾘｽﾄ へ移動します。 

22 Unselected ﾘｽﾄの Sstub = 220 mils、 Lstub = 120 mils をﾀﾞﾌﾞﾙｸﾘｯｸします。

このﾊﾟﾗﾒｰﾀの組み合わせが Selected ﾘｽﾄ へ移動され、この組み合わせのﾃﾞｰﾀが
ﾌﾟﾛｯﾄに表示されます。

23 Select Parameters ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの OK ﾎﾞﾀﾝをｸﾘｯｸして、この変更事項を
適用し、ﾀﾞｲｱﾛｸﾞをｸﾛｰｽﾞします。

Edit Curve Group ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Parameter Combinations欄に入力された “Lstub = 
120.0 Sstub = 220.0”が表示されます。
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24 Edit Curve Group ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの OK ﾎﾞﾀﾝをｸﾘｯｸして、この変更事項を
適用し、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞします。

ﾌﾟﾛｯﾄは  Sstub = 220 mils、Lstub = 120 milへの S21の応答に更新されます。
ｶｰﾌﾞｸﾞﾙｰﾌﾟ  par_dstub への入力が Curve Group Legendの中に表示されます。ﾌﾟﾛｯﾄ
は以下のようになっているはずです。
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25 Lstub = 280 milでの応答を追加するために、 response viewer のﾒｲﾝﾒﾆｭｰか
ら Curve ⇒ Add Curve Group を選択します。

Add Curve Group ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。このｶｰﾌﾞｸﾞﾙｰﾌﾟはﾃﾞﾌｫﾙﾄ
名である par_dstub_2を使用します。前に par_dstubで使用した同じ手順
に従って、  Lstub = 280 mil、 Sstub = 220 milの S21 の応答を表示するために
ｶｰﾌﾞｸﾞﾙｰﾌﾟを設定します。ﾌﾟﾛｯﾄは以下のようになっているはずです。

これには、legendの Left Axis pane のｶｰﾌﾞｸﾞﾙｰﾌﾟ par_dstub をﾏｳｽの右ﾎﾞﾀﾝ
でｸﾘｯｸし、ﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰから “Edit Curve Group”を選択する方法もあり
ます。Edit Curve group ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを使い、このﾊﾟﾗﾒｰﾀの組み合わせを
このｶｰﾌﾞｸﾞﾙｰﾌﾟに追加することもできます。 その結果、両方のﾊﾟﾗﾒｰﾀの
組み合わせを表現する１つのｼﾝﾎﾞﾙのついた１つのｶｰﾌﾞｸﾞﾙｰﾌﾟとなりま
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す。  これは複数の表示値 (例えば S21 と S11 ) が必要な時には便利です。
各表示値は異なるｼﾝﾎﾞﾙを使いますが、１つの表示値のついた各ﾊﾟﾗﾒｰﾀ
の組み合わせは同じｼﾝﾎﾞﾙを使います。以下に例を示します。

初めはﾌｨﾙﾀｰ設計のｺﾞｰﾙは 5.0 GHzと 6.0 GHzの間のｽﾄｯﾌﾟﾊﾞﾝﾄﾞでした。 
Lstub=120 のﾌﾟﾛｯﾄを Lstub=280のﾌﾟﾛｯﾄと比較してみると、要求された 
ｽﾄｯﾌﾟﾊﾞﾝﾄﾞのﾌｨﾙﾀｰはおよそ、2つのｶｰﾌﾞの中間で落ち込んでいることが
わかります。従って、 220 milの値が、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの Lstub の名目値に
選ばれます。 220 milの名目値が Sstubに選ばれます。

Optimization
ﾁｭｰﾄﾘｱﾙの次の節では、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの設定方法と実行方法を説明します。

ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝについての詳細は、Sonnet User’s Guide の 166 ﾍﾟｰｼﾞの
“Optimization ”をご覧ください。

par_dstub.sonがまだ project editorの中でｵｰﾌﾟﾝされていなければ、 project editor
の中でこのﾌｧｲﾙをｵｰﾌﾟﾝします。



Sonnet Supplemental Tutorials

32

Entering New Nominal Values

定義されたﾊﾟﾗﾒｰﾀ Lstub と Sstubの両方を使ってｵﾌﾟﾃｨﾏｲｽﾞすると、この
種類の回路には有効ですが、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝは処理時間のために Lstub の
１つのﾊﾟﾗﾒｰﾀのみを使用しています。

Sstubに使用される名目値は 200 milになります。これは実際には両方の
ﾊﾟﾗﾒｰﾀと、ｵﾌﾟﾃｨﾏｲｽﾞされたﾊﾟﾗﾒｰﾀのｸﾞﾘｯﾄﾞ上の最も近い値を使用して、
ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを実行したことによって到達した値です。 

26 回路のﾊﾟﾗﾒｰﾀ Sstub をﾀﾞﾌﾞﾙｸﾘｯｸします。

Sstubのための Parameter Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。

27 Nominal Value ﾃｷｽﾄ入力ﾎﾞｯｸｽの名目値を 200に変更します。

28 OK ﾎﾞﾀﾝをｸﾘｯｸしてﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞし、新しい名目値を適用しま
す。

Sstubの新しい名目値を用いて、回路が再表示されます。

! WARNING
Properties ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを使用して、ﾊﾟﾗﾒｰﾀの名目値を変更することをお
勧めします。それはこの方法で名目値を変えても、ﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙの以前
の応答ﾃﾞｰﾀには何も影響を与えないからです。Reshape のような修正
ｺﾏﾝﾄﾞを使って回路を変更することによってﾊﾟﾗﾒｰﾀの名目値を変更する
と、保存する時にすべての以前の応答ﾃﾞｰﾀがﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙから削除され
てしまいます。

Setting Up an Optimization

29 Project editorのﾒｲﾝﾒﾆｭｰから Analysis ⇒ Setup を選択します。

Analysis Setup ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。
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30 Analysis Control ﾄﾞﾛｯﾌﾟﾘｽﾄから Optimization を選択します。

解析の種類として optimization が選択されます。 ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝに必要な
入力ができるようにﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの表示が変わります。初めはﾊﾟﾗﾒｰﾀ用
に名目値が記入されていないことに注目してください。これは、範囲が
何も設定されていないためです。

31 Parameters ﾘｽﾄの右側の Edit ﾎﾞﾀﾝをｸﾘｯｸします。

Optimization Parameters ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。

Analysis Control
ﾄﾞﾛｯﾌﾟﾘｽﾄ

Parameters ﾘｽﾄ

Optimization Goals
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1つのﾊﾟﾗﾒｰﾀ Lstubだけがこのｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝに使用されます。 Lstubの範
囲は 100 milから 300 milです。 

32 Lstubの横の Optimize ﾁｪｯｸﾎﾞﾀﾝをｸﾘｯｸします。

Lstubのﾊﾟﾗﾒｰﾀがｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝに使用されるために選択されます。名目
値が Nominal 入力ﾎﾞｯｸｽに表示されることに注目してください。名目値
を変えたいのであれば、新しい値を入力して変えることができます。回
路は新しい名目値で再表示されます。これはこのﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙでは最初
のｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝなので、 Min と Maxの入力ﾎﾞｯｸｽは空になっています。
もし、以前のｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝが実行されていれば、最後に入力された値
が残っているでしょう。

! WARNING
ﾊﾟﾗﾒｰﾀの設定を修正したり、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙを変えると、前に存在
していたｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの反復がﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙから削除される原因とな
ります。

33 Lstubの列の Min入力ﾎﾞｯｸｽに 100と入力します。

ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのために、 Lstub のﾊﾟﾗﾒｰﾀの最小値が 100 milに設定されま
す。

34 Lstubの列の  Max入力ﾎﾞｯｸｽに 300 と入力します。

ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのために、 Lstubの最大値が 300 milに設定されます。
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35 OK ﾎﾞﾀﾝをｸﾘｯｸしてこの変更事項を適用し、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞしま
す。

ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽがｸﾛｰｽﾞされると、定義したばかりのｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの
ﾊﾟﾗﾒｰﾀへの入力で、Analysis Setup ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが更新されます。 

変化させるﾊﾟﾗﾒｰﾀとその範囲を指定したので、次はｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの
ｺﾞｰﾙを設定する必要があります。これはこのﾌﾟﾛｼﾞｪｸﾄでは最初の
ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝなので、前に定義されたｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙは何もな
く、ﾘｽﾄは空になっています。ｺﾞｰﾙが存在しないと、 Edit ﾎﾞﾀﾝと Delete 
ﾎﾞﾀﾝは使用できません。 Edit ﾎﾞﾀﾝは修正したりｺﾞｰﾙをつくれます。Delete 
ﾎﾞﾀﾝはﾘｽﾄからｺﾞｰﾙを削除します。 

この例題で前述したように、ﾌｨﾙﾀｰのｺﾞｰﾙは 1-4 GHzと 7-10 GHz の
ﾊﾟｽﾊﾞﾝﾄﾞと、5-6 GHzのｽﾄｯﾌﾟﾊﾞﾝﾄﾞです。ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙはそれに
応じて設定されます。この場合、3つのｺﾞｰﾙはすべて同様に重要なので、
各々、ﾃﾞﾌｫﾙﾄの Weight  1.0を使用します。１つのｺﾞｰﾙがより重要となる
場合には、他のｺﾞｰﾙよりもより大きな値のWeight をそれに割り当てるこ
とを emに指示すると、よりその特定のｺﾞｰﾙに到達することに集中して
計算します。
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36 Optimization Goals ﾘｽﾄの右側にある Add ﾎﾞﾀﾝをｸﾘｯｸします。

Optimization Goal Entry ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。

１つめのｺﾞｰﾙは１つめのﾊﾟｽﾊﾞﾝﾄﾞに該当します。従って、周波数の範囲
を 1.0 GHzから 4.0 GHzに設定します。使用できる周波数ｽｨｰﾌﾟにはいく
つかのﾀｲﾌﾟがありますが、この ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝでは、ﾃﾞﾌｫﾙﾄの ABS 
ｽｨｰﾌﾟを使います。

37 ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Frequency Specificationの欄の Start ﾃｷｽﾄ入力ﾎﾞｯｸｽに 1.0 
と入力します。

このｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙの開始周波数が 1.0 GHzに設定されます。

38 ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Frequency Specificationの欄の Stop ﾃｷｽﾄ入力ﾎﾞｯｸｽに 4.0
と入力します。

このｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙの終了周波数が 4.0 GHzに設定されます。これ
で このｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙの周波数ｽｨｰﾌﾟの設定が終わります。

これは１つめのﾊﾟｽﾊﾞﾝﾄﾞなので、ﾕｰｻﾞのｺﾞｰﾙは -1.0 dBより大きな 
DB[S21] でなくてはいけません。 

39 式の左側にある Response Type ﾄﾞﾛｯﾌﾟﾘｽﾄから DBを選択します。

これはﾃﾞﾌｫﾙﾄなので、 DB は既に選択されています。

Sweep
Type
Specification

Response Type
drop list

Response
drop list

Operand

Goal Type

Value text
entry box

Frequency
Controls
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40 Response ﾄﾞﾛｯﾌﾟﾘｽﾄから S21 を選択します。

41 Operand ﾄﾞﾛｯﾌﾟﾘｽﾄから “ >” を選択します。

42 Goal Type ﾄﾞﾛｯﾌﾟﾘｽﾄから Value を選択します。

ここでの選択により、特定の値を入れることができます。これはﾃﾞﾌｫﾙﾄです。
従って、 ﾕｰｻﾞが別のﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙか ( もしﾌﾟﾛｼﾞｪｸﾄが ﾈｯﾄﾜｰｸﾌﾟﾛｼﾞｪｸﾄであれば
)、お使いのﾌﾟﾛｼﾞｪｸﾄの別のﾈｯﾄﾜｰｸを設定することもできます。その場合、ﾕｰｻﾞ
が選んだ応答に合わせたい回路に１つの応答を選ぶことができます。

43 Value入力ﾎﾞｯｸｽの中に -1.0を入力します。

これでｺﾞｰﾙが DB[S21] > -1.0 dBに設定されます。

44 OK ﾎﾞﾀﾝをｸﾘｯｸして、この変更事項を適用し、ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞしま
す。

Analysis Setup ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが更新されます。このｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙの入力
が Optimization Goals ﾘｽﾄに表示されます。

他の 2つのｺﾞｰﾙも同じ方法で入力します。 2つめのｺﾞｰﾙは、 5.0 GHz から 6.0 GHz 
の間で adaptive ｽｨｰﾌﾟし、 所望の応答は、  DB[S21] < -30.0 dBというものです。こ
れはｽﾄｯﾌﾟﾊﾞﾝﾄﾞです。 3つめのｺﾞｰﾙは 7.0 GHz から 10.0 GHzの間で、 adaptive 
ｽｨｰﾌﾟし、所望の応答は、 DB[S21] > -1.0というものです。これらのｺﾞｰﾙの入力が
終了すると、Optimization Goals ﾘｽﾄは以下のようになっているはずです。
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これでｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの設定は終了です。

Running an Optimization 

このｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝは 2 GHz Pentium 4上では、およそ 6.5 分 かかりまし
た。 

45 Project editorのﾒｲﾝﾒﾆｭｰから Project ⇒ Analyze を選択します。

解析ﾓﾆﾀｰの出力ｳｨﾝﾄﾞｳが画面に表示されます。 

TIP
Project editorのﾂｰﾙﾊﾞｰの Analyze ﾎﾞﾀﾝをｸﾘｯｸすることも可能です。

46 まだ応答ﾃﾞｰﾀを表示していなければ、解析ﾓﾆﾀｰの 出力ｳｨﾝﾄﾞｳの Response 
Data ﾎﾞﾀﾝをｸﾘｯｸします。

これでｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝが進行する様子を観察することができます。１つ
めと、現在と、最良の反復の誤差が表示され、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝが進行す
るに従って更新されます。応答ﾃﾞｰﾀがｳｨﾝﾄﾞｳの下に表示されます。

いくつかの反復が他のものよりも早く終わることに気づかれることで
しょう。これは、 em が前 の反復で計算された応答ﾃﾞｰﾀの一部を再利用し
ているからです。

解析が完了したら、response viewer をｵｰﾌﾟﾝして結果を見てください。こ
のｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝは結論を出すのに多くの反復を使用したので、 response 
viewer と Edit Curve Group ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｵｰﾌﾟﾝするのが少し遅くなるか
もしれないことをご承知おきください。 
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TIP
Response viewerを使用して、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの実行中にｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝで生成され
たﾃﾞｰﾀを観察することができます。Response viewer は、生成されている任意の
ﾃﾞｰﾀを図示することができます。こうすればｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを中止したり、新し
いﾊﾟﾗﾒｰﾀ範囲または結果が好ましくない時に新しいｺﾞｰﾙを用いて再びｽﾀｰﾄさせる
ことができます。ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを実行している時に、ﾃﾞｰﾀを観察し続けたいの
であれば response viewerの Freshen Files ｺﾏﾝﾄﾞを使ってください。

Observing your Optimization Data

最良の反復をﾌﾟﾛｯﾄすると、ﾊﾟﾗﾒｰﾀのｵﾌﾟﾃｨﾏｲｽﾞされた値を使うべきか否
かの判断ができます。 

47 解析ﾓﾆﾀｰ のﾒｲﾝﾒﾆｭｰから Project ⇒ View Response ⇒ New Graph を選択し
ます。

名目値のﾊﾟﾗﾒｰﾀの組み合わせの DB[S11] の応答を表示した response 
viewer が 画面に表示されます。含まれている応答ﾃﾞｰﾀの量によっては、
ﾌﾟﾛｼﾞｪｸﾄが response viewer にﾛｰﾄﾞされるのに若干時間がかかるかもしれ
ません。 

48 Legend の中で DB[S11] のｶｰﾌﾞｸﾞﾙｰﾌﾟを ｸﾘｯｸして、これを選択し、
response viewerのﾒｲﾝﾒﾆｭｰから Curve ⇒ Edit Curve Group を選択します。 

Edit Curve Group ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。 

49 Edit Curve Groups ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの Data Collection ﾄﾞﾛｯﾌﾟﾘｽﾄから
Optimized を選択します。

ﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙはﾊﾟﾗﾒｰﾀｽｨｰﾌﾟﾃﾞｰﾀと、ｵﾌﾟﾃｨﾏｲｽﾞされたﾃﾞｰﾀの両方を含ん
でいるので、このﾄﾞﾛｯﾌﾟﾘｽﾄが使えるということに注目してください。

50 入力ﾎﾞｯｸｽをﾀﾞﾌﾞﾙｸﾘｯｸして、 DB[S11] を Unselected ﾘｽﾄ へ移動します。

51 入力ﾎﾞｯｸｽをﾀﾞﾌﾞﾙｸﾘｯｸして、 DB[S21] を Selected ﾘｽﾄ へ移動します。

ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙは、 DB[S21] の応答について設定されたので、この
応答をﾌﾟﾛｯﾄしてみます。
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ｵﾌﾟﾃｨﾏｲｽﾞされたﾃﾞｰﾀを選択した時には、ﾊﾟﾗﾒｰﾀの組み合わせは次のよ
うに更新されていることに注目してください。

ｵﾌﾟﾃｨﾏｲｽﾞされたﾃﾞｰﾀを選択した時に、ﾃﾞﾌｫﾙﾄで最良の反復がﾌﾟﾛｯﾄされ
ます。もしｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝがまだ実行中であればこれは、それまでに計
算された最良の反復を常にﾌﾟﾛｯﾄするのに便利な方法です。   Response 
viewerのﾂｰﾙﾊﾞｰの Freshen Files ﾎﾞﾀﾝを押すと、常に最良の反復が表示され
ます。

Select Iterations ﾎﾞﾀﾝをｸﾘｯｸした場合は、ﾌﾟﾛｯﾄが可能な 25 すべてのﾊﾟﾗﾒｰﾀ
値が表示されたﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。ここでは、最良の反復で
の応答を見たいので、このｶｰﾌﾞｸﾞﾙｰﾌﾟのﾊﾟﾗﾒｰﾀ値を変える必要はありま
せん。
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52 OK ﾎﾞﾀﾝをｸﾘｯｸしてﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞし、変更事項を適用します。

ﾌﾟﾛｯﾄは最良の反復に DB[S21] を示して更新されます。これは以下のよ
うなﾌﾟﾛｯﾄになっているはずです。
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ご覧のように、ｵﾌﾟﾃｨﾏｲｽﾞされた回路は、5 - 6 GHzのﾊﾟｽﾊﾞﾝﾄﾞと 1 - 4 
GHZと 7-10 GHのｽﾄｯﾌﾟﾊﾞﾝﾄﾞの所望の応答を生成しています。

Accepting the Optimized Values
ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝによって所望の応答を得ることが達成されたので、次は project 
editorに戻ってｵﾌﾟﾃｨﾏｲｽﾞされた値で、ﾊﾟﾗﾒｰﾀの名目値を更新します。 

もしﾌﾟﾛｼﾞｪｸﾄの par_dstub がまだ project editorでｵｰﾌﾟﾝしていたら、Step55 から進
んでください。

53 Response viewer の Curve Group legendのｶｰﾌﾞｸﾞﾙｰﾌﾟ par_dstubをｸﾘｯｸし
ます。 

これでﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙが選択され、ﾌﾟﾛｼﾞｪｸﾄﾒﾆｭｰが使えるようになります。

54 Response viewer のﾒｲﾝﾒﾆｭｰから Project ⇒ Edit を選択します。 

par_dstubがｵｰﾌﾟﾝした project editor が画面に表示されます。



Chapter 2  Parameter Sweep and Optimization Tutorial

43

55 Project editorのﾒｲﾝﾒﾆｭｰから Analysis ⇒ Optimization Results  を選択しま
す。

Optimization Results ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。

2つのﾊﾟﾗﾒｰﾀの名目値は、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのはじめに入力された値である
ことに注目してください。しかし、2つのﾊﾟﾗﾒｰﾀのｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝ結果は
最後の欄に表示されます。 Sstub はｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝでは使用されていない
ので、そのｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝ結果は名目値と同じです。

56 Update ﾎﾞﾀﾝをｸﾘｯｸして、現在の名目値とｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝ結果を置き換え
ます。

Nominal入力ﾎﾞｯｸｽの入力がｵﾌﾟﾃｨﾏｲｽﾞされた値に更新されていることに
注目してください。

57 OK ﾎﾞﾀﾝをｸﾘｯｸしてﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞし、変更事項を適用します。

回路がﾊﾟﾗﾒｰﾀの新しい名目値で再表示されていることに注目してくださ
い。ﾊﾟﾗﾒｰﾀの長さは、ｾﾙｻｲｽﾞの整数倍になっていないので、図形はもは
や正確なｸﾞﾘｯﾄﾞ上にはありません。このことは、 Ctrl ｷｰ を押しながらM
を押してｾﾙの充填を無効にし、現在の図形を見るとわかります。 ｾﾙの充
填は em が解析する実際の金属を表わしています。 
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Em で解析された実際の金属導体は、ｵﾌﾟﾃｨﾏｲｽﾞされた値と同じではあり
ません。  Em は実際には、“ ｸﾞﾘｯﾄﾞ上 ”にある回路を解析したものからつ
くられたﾃﾞｰﾀから補間を施しました。もしもｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙに全
体の周波数ｽｨｰﾌﾟが含まれていなければ、全体の帯域が必ず妥当な結果
を示すように、お使いの周波数全域に渡って全体のｽｨｰﾌﾟを実行するの
がよいでしょう。以下に周波数ｽｨｰﾌﾟの実行について説明します。 

Em が以前に計算された応答ﾃﾞｰﾀを使うためには、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの結果
に、“ ｸﾞﾘｯﾄﾞ上 ”に最も近いようなﾊﾟﾗﾒｰﾀ値を編集すべきです。例えば、
この場合では、 Lstub にｵﾌﾟﾃｨﾏｲｽﾞされた値は 191.80662641です。 Lstub の
名目値を編集して 190 にすべきです。これは、ｾﾙｻｲｽﾞが  10で、ｸﾞﾘｯﾄﾞ
上にあります。 

58 Project editorのﾒｲﾝﾒﾆｭｰから Analysis ⇒ Setupを選択します。

Analysis Setup ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。

59 Analysis Control ﾄﾞﾛｯﾌﾟﾘｽﾄから Adaptive Sweep (ABS) を選択します。

Adaptive ｽｨｰﾌﾟに適合するようにﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの表示が変わります。 この
解析に 2 - 10 GHzの周波数帯域を定義するために、Start ﾃｷｽﾄ入力ﾎﾞｯｸｽに
2.0 GHz 、 Stop ﾃｷｽﾄ入力ﾎﾞｯｸｽに 10 GHz と入力します。

60 OK ﾎﾞﾀﾝをｸﾘｯｸしてﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞし、変更事項を適用します。

61 Analyze ﾎﾞﾀﾝをｸﾘｯｸして em の解析を開始します。 

保存するように指示がされたら、解析する前に回路を保存してくださ
い。

62 解析が完了したら、解析ﾓﾆﾀｰのﾂｰﾙﾊﾞｰの View Response ﾎﾞﾀﾝをｸﾘｯｸしま
す。

Response viewer が画面に表示され、ｶｰﾌﾞｸﾞﾙｰﾌﾟ par_dstubの DB[S11] の項
目を表示します。
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63 ｶｰﾌﾞｸﾞﾙｰﾌﾟ par_dstubをﾏｳｽの右ﾎﾞﾀﾝでｸﾘｯｸし、 表示されたﾎﾟｯﾌﾟｱｯﾌﾟﾒﾆｭｰ
から Edit Curve Groupを選択します。

DB[S21] を選択して表示し、DB[S11] を not selected ﾘｽﾄへ移動し、
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｸﾛｰｽﾞします。 ﾌﾟﾛｯﾄは以下のようになっているはずです。

この結果は、設計の基準に十分近いものなので、このｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝは
成功であると判断されます。このﾁｭｰﾄﾘｱﾙのはじめで強調したように、
ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの行程をわかりやすく説明するために、ｼﾝﾌﾟﾙな例題を選
びました。

しかし、ほとんどのｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝの問題点はかなり複雑で簡単にはい
かないということをご承知おきください。 設計者は回路についての知識
や設計の経験に基づいてﾊﾟﾗﾒｰﾀ、 ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟ、ｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝのｺﾞｰﾙに
ついて判断をくだす必要があります。時折、進行中のｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを
観察し、その実行の可能性を判断し、必要であればｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを中
止し、新しい名目値やﾃﾞｰﾀ範囲でｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを実行し直さねばなら
ないでしょう。


