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Chapter 12 Netlist Project 
Analysis

ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄは強力な回路解析ﾂｰﾙです。ﾈｯﾄﾘｽﾄが使われるのは次の
ような時です。

• Sonnet のﾌﾟﾛｼﾞｪｸﾄを縦続接続する。:使用できるのであれば、前からあ
るｻﾌﾞﾌﾟﾛｼﾞｪｸﾄのﾃﾞｰﾀを使って、複数のﾌﾟﾛｼﾞｪｸﾄを解析したり、組み合わせ
ることができます。これは大きく複雑な回路をいくつかに分割して emの解
析が必要な時には特に便利です。ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄを解析している時に、
ｻﾌﾞﾌﾟﾛｼﾞｪｸﾄで使用されている周波数ｽｨｰﾌﾟに違いがある場合は、emは自動
的にそれらの周波数間の値を補間します。ﾈｯﾄﾘｽﾄのすべてのｻﾌﾞﾌﾟﾛｼﾞｪｸﾄで
同じ周波数ｽｨｰﾌﾟを行うことも可能です。回路のｻﾌﾞﾃﾞｨﾋﾞｼﾞｮﾝについての詳
細は、第 13章の “Circuit Subdivision”をご覧ください。

• S、Y、 Z ﾊﾟﾗﾒｰﾀのﾃﾞｰﾀﾌｧｲﾙを縦続接続する。:複数の S、 Y、 Z ﾊﾟﾗﾒｰﾀ
のﾃﾞｰﾀﾌｧｲﾙを読んで組み合わせることができます。Emによる解析
で、別のﾍﾞﾝﾀﾞｰのｿﾌﾄｳｪｱを使って得た結果を組み合わせたい時には
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特に便利です。ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄを解析している時、ﾃﾞｰﾀﾌｧｲﾙ間の周
波数に差がある場合には、emは自動的に各周波数の値を補間しま
す。

• ﾓﾃﾞﾘﾝｸﾞされた要素を回路の中に挿入する。:抵抗、ｷｬﾊﾟｼﾀ、ｲﾝﾀﾞｸﾀ、
伝送線路などのﾓﾃﾞﾘﾝｸﾞされた要素は図形のｻﾌﾞﾌﾟﾛｼﾞｪｸﾄや S、Y、
Z ﾊﾟﾗﾒｰﾀのﾃﾞｰﾀﾌｧｲﾙと結合することができます。

Networks
ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄは各要素を一緒に結合した１つまたは１つ以上のﾈｯﾄﾜｰｸ
から構成されるﾈｯﾄﾘｽﾄを含んでいます。ﾈｯﾄﾘｽﾄは、ﾈｯﾄﾘｽﾄの個々の要素
のﾎﾟｰﾄがﾉｰﾄﾞを使って他の要素のﾎﾟｰﾄと結合しているﾏｯﾌﾟをつくりま
す。ﾉｰﾄﾞはﾈｯﾄﾘｽﾄの要素間の関係を表現します。

1 2 3 4

GND

steps.son steps.son

example_net

1 2
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上の図は、下の project editor で表示されたﾈｯﾄﾘｽﾄで表現されたﾈｯﾄﾜｰｸを
示しています。ﾉｰﾄﾞは、番号のつけられた黒い点で表現されています。
図形ﾌﾟﾛｼﾞｪｸﾄ steps.sonは、図形ﾌﾟﾛｼﾞｪｸﾄではﾎﾟｰﾄ１に対応するﾉｰﾄﾞ１
と、ﾎﾟｰﾄ 2に対応するﾉｰﾄﾞ 2でﾉｰﾄﾞ１とﾉｰﾄﾞ 2の間に接続されています。
抵抗はﾉｰﾄﾞ 3とﾉｰﾄﾞ 4の間に接続されています。ｷｬﾊﾟｼﾀはﾉｰﾄﾞ 3と
ｸﾞﾗｳﾝﾄﾞの間に接続されています。ﾌﾟﾛｼﾞｪｸﾄ steps.son は、ﾉｰﾄﾞ 4に対応す
るﾎﾟｰﾄ１とﾉｰﾄﾞ 3に対応するﾎﾟｰﾄ 2で、ﾉｰﾄﾞ 3とﾉｰﾄﾞ 4の間に接続されて
います。ﾈｯﾄﾜｰｸ example_net のﾎﾟｰﾄ１はﾉｰﾄﾞ１に対応し、ﾈｯﾄﾜｰｸのはﾉｰﾄﾞ
４に対応しています。

上に描かれたﾈｯﾄﾘｽﾄでご覧の通り、ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄは単なるこれらの要
素のﾘｽﾄです。要素名の後の最初の数字が、要素のﾎﾟｰﾄ１に対応する
ﾈｯﾄﾜｰｸﾉｰﾄﾞであり、2つめの数字が要素のﾎﾟｰﾄ 2に対応するﾈｯﾄﾜｰｸﾉｰﾄﾞ
であり、１つの要素の中のすべてのﾎﾟｰﾄは以下同様であることにご注目
ください。

Netlist Project Analyses
ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄの解析は、次のようなｽﾃｯﾌﾟで行なわれます。

1 ﾈｯﾄﾘｽﾄ ﾓｰﾄﾞでは、 project editorを使用してﾈｯﾄﾘｽﾄを入力します。Project 
editorによってﾈｯﾄﾘｽﾄのﾈｯﾄﾜｰｸ、ﾈｯﾄﾜｰｸ要素、ﾌﾟﾛｼﾞｪｸﾄ要素、ﾓﾃﾞﾘﾝｸﾞさ
れた要素、そしてﾃﾞｰﾀﾌｧｲﾙ要素を作成したり、編集することができま
す。また、ﾈｯﾄﾘｽﾄの中でﾊﾟﾗﾒｰﾀを定義することや解析ｺﾝﾄﾛｰﾙを入力する
こともできます。

2 Emは、回路と解析ｺﾝﾄﾛｰﾙ情報を含むﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄを読み込みます。
このﾌｧｲﾙには、 S、 Y、 Z ﾊﾟﾗﾒｰﾀのﾃﾞｰﾀﾌｧｲﾙ、ﾓﾃﾞﾘﾝｸﾞされた要素、図形
ｻﾌﾞﾌﾟﾛｼﾞｪｸﾄ ( ﾌﾟﾛｼﾞｪｸﾄ要素 )、そしてﾈｯﾄﾜｰｸ要素が含まれています。

3 Emは、解析ｺﾝﾄﾛｰﾙの入力を、ﾈｯﾄﾜｰｸﾌｧｲﾙで起動された各電磁界解析を
実行するﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄの一部として使用します。独自の解析ｺﾝﾄﾛｰﾙを
使って、図形ｻﾌﾞﾌﾟﾛｼﾞｪｸﾄが解析されるような方法で、解析ｺﾝﾄﾛｰﾙをつ
くることも可能です。ﾈｯﾄﾘｽﾄｻﾌﾞｼﾞｪｸﾄは、常に現在のﾈｯﾄﾘｽﾄから解析
ｺﾝﾄﾛｰﾙを継承します。

4 いったん図形ｻﾌﾞｼﾞｪｸﾄの解析が終了すると、emはﾈｯﾄﾘｽﾄの中で設定さ
れた回路の解析を実行します。
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5 Emは、電磁界解析の結果と回路の結果を組み合わせ、所望の出力結果
を得ます。

上記のｽﾃｯﾌﾟは、電磁界解析と回路解析両方にあてはまります。全体の解析で電
磁界解析か回路解析だけに限られる場合は、このｽﾃｯﾌﾟのいくつかが除かれます。

Creating a Netlist
Project editorを使ってﾈｯﾄﾘｽﾄを作成することができます。新しいﾈｯﾄﾘｽﾄを
作成するには、project editorのﾒｲﾝﾒﾆｭｰから File ⇒ New Netlist を選択しま
す。Project editor のﾂｰﾙﾊﾞｰとﾒﾆｭｰは、ﾈｯﾄﾘｽﾄｴﾃﾞｨﾀ用に変わり、ﾈｯﾄﾘｽﾄに
要素やﾈｯﾄﾜｰｸを追加することができるようになります。

ｲﾆｼｬﾙ ( 初期）のﾈｯﾄﾘｽﾄﾌｧｲﾙはﾃﾞﾌｫﾙﾄで Netという名前のついた 2 ﾎﾟｰﾄの
ﾈｯﾄﾜｰｸを含んでいます。ﾈｯﾄﾘｽﾄの最後のﾈｯﾄﾜｰｸはﾒｲﾝﾈｯﾄﾜｰｸです。
ﾒｲﾝﾈｯﾄﾜｰｸは、ﾕｰｻﾞがこのﾈｯﾄﾘｽﾄの中で解決法を探しているﾈｯﾄﾜｰｸです。
ﾈｯﾄﾘｽﾄを解決してる時は、解決で生成された応答ﾃﾞｰﾀは、ﾒｲﾝﾈｯﾄﾜｰｸの
ためのものです。

入力ﾎﾞｯｸｽの上をﾀﾞﾌﾞﾙｸﾘｯｸすることにより、ﾎﾟｰﾄ数を含むこのﾈｯﾄﾜｰｸの
名前や属性を編集することができます。これは、ﾈｯﾄﾘｽﾄで行われたすべ
ての入力について同じことができます。それら (入力項目 )の上を
ﾀﾞﾌﾞﾙｸﾘｯｸし、入力を編集したり、ｱｲﾃﾑを選択することのできる
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｵｰﾌﾟﾝし、次にﾒｲﾝﾒﾆｭｰから Tools ⇒ Modify ｺﾏﾝﾄﾞを選択し
てください。

Adding Networks

ﾈｯﾄﾘｽﾄにﾈｯﾄﾜｰｸを追加するには、project editor のﾒｲﾝﾒﾆｭｰから Tools ⇒
Add Network を選択するか、またはﾂｰﾙﾊﾞｰの Add Network ﾎﾞﾀﾝをｸﾘｯｸしま
す。  Edit Network ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。この
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを使って、ﾈｯﾄﾜｰｸ内のﾎﾟｰﾄ数や、ﾎﾟｰﾄの終端を定義した
り、ﾈｯﾄﾘｽﾄのﾉｰﾄﾞ番号をﾈｯﾄﾜｰｸのﾎﾟｰﾄに割り当てることができます。
ﾈｯﾄﾜｰｸを追加する時には、ﾈｯﾄﾜｰｸは常にﾈｯﾄﾘｽﾄのためのﾒｲﾝﾈｯﾄﾜｰｸとし
て追加されます。予め存在するﾈｯﾄﾜｰｸはこのﾌｧｲﾙに付け加えられます。
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ﾈｯﾄﾜｰｸの中に含むことのできる 4種類の要素があります。ﾈｯﾄﾜｰｸ、
ﾓﾃﾞﾙ、ﾃﾞｰﾀﾌｧｲﾙ、ﾌﾟﾛｼﾞｪｸﾄです。

Adding Network Elements

要素の１つめの種類はﾈｯﾄﾜｰｸ要素です。ﾈｯﾄﾜｰｸ要素によって、以前定義
された別のﾈｯﾄﾜｰｸを、現在のﾈｯﾄﾜｰｸの一部として使用することができま
す。これは１つのﾈｯﾄﾜｰｸをいくつも複製したい場合に便利です。

ﾈｯﾄﾜｰｸ要素をﾈｯﾄﾘｽﾄへ追加するには、追加したいﾈｯﾄﾜｰｸの上をｸﾘｯｸし、
次にﾒｲﾝﾒﾆｭｰから Tools ⇒ Add Network Element を選択するか、 project 
editorのﾂｰﾙﾊﾞｰのAdd Network Elementをｸﾘｯｸします。 Edit Networkﾀﾞｲｱﾛｸﾞ
ﾎﾞｯｸｽに似たﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されますが、このﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽでは名
前は変えられません。ﾄﾞﾛｯﾌﾟﾛｽﾄの中から存在するﾈｯﾄﾜｰｸの名前を選ん
で、どのﾈｯﾄﾜｰｸを使用したいかを選択します。現在のﾈｯﾄﾜｰｸの上に定義
されたﾈｯﾄﾜｰｸだけが使用できます。

Adding Modeled Elements

ﾓﾃﾞﾘﾝｸﾞされる要素は、抵抗、ｷｬﾊﾟｼﾀ、ｲﾝﾀﾞｸﾀ、理想的な伝送線路また
は物理的な (実際の )伝送線路です。ﾓﾃﾞﾘﾝｸﾞされる要素をﾈｯﾄﾘｽﾄへ追
加するには、ﾒｲﾝﾒﾆｭｰから Tools ⇒ Add Modeled Elementを選択するか、
または project editorのﾂｰﾙﾊﾞｰの Add Modeled Element ﾎﾞﾀﾝをｸﾘｯｸします。
Edit Elementﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。ﾄﾞﾛｯﾌﾟﾘｽﾄから追加した
いﾓﾃﾞﾘﾝｸﾞされる要素の種類を選択し、このﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの下にある
ﾃｷｽﾄ入力ﾎﾞｯｸｽの中に、その要素のﾊﾟﾗﾒｰﾀを入力します。ﾊﾟﾗﾒｰﾀが
ﾈｯﾄﾘｽﾄの中で定義されている場合は、１つのﾊﾟﾗﾒｰﾀを、ﾓﾃﾞﾘﾝｸﾞされる
要素のﾊﾟﾗﾒｰﾀの値として、入力するかもしれません。要素のﾎﾟｰﾄと
ｸﾞﾗｳﾝﾄﾞのそれぞれに入力ﾎﾞｯｸｽが表示されます。各ﾎﾟｰﾄに対して、
ﾈｯﾄﾜｰｸの所望するﾉｰﾄﾞ番号をここに入力してください。

Adding Data File Elements

ﾃﾞｰﾀﾌｧｲﾙ要素はﾕｰｻﾞがﾈｯﾄﾜｰｸの中に含みたいと思う応答ﾃﾞｰﾀを含む
ﾃﾞｰﾀﾌｧｲﾙです。応答ﾃﾞｰﾀは、 Sonnet の解析からのｵﾌﾟｼｮﾝの出力ﾌｧｲﾙか、
または測定ﾃﾞｰﾀのように Touchstone や Super Compact ﾌｫｰﾏｯﾄのﾃﾞｰﾀでも
可能です。ﾃﾞｰﾀﾌｧｲﾙ要素をﾈｯﾄﾘｽﾄへ追加するには、ﾒｲﾝﾒﾆｭｰから Tools
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⇒Add Data File Element を選択するか、または project editor のﾂｰﾙﾊﾞｰの
Add Data File Element ﾎﾞﾀﾝをｸﾘｯｸします。Browse ｳｨﾝﾄﾞｳが表示されて、
ﾈｯﾄﾜｰｸに含みたいﾃﾞｰﾀﾌｧｲﾙを選択できます。いったんこのﾌｧｲﾙが読み込
まれると、 Edit Element ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されて、ﾎﾟｰﾄに対して
ﾈｯﾄﾘｽﾄﾉｰﾄﾞ番号を定義することができます。

Adding Project Elements

ﾌﾟﾛｼﾞｪｸﾄ要素は、別の Sonnet のﾌﾟﾛｼﾞｪｸﾄをﾈｯﾄﾜｰｸの一部として使用する
ことができます。ﾌﾟﾛｼﾞｪｸﾄは図形かﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄです。ﾌﾟﾛｼﾞｪｸﾄ要素
をﾈｯﾄﾘｽﾄへ追加するには、ﾒｲﾝﾒﾆｭｰから Tools ⇒ Add Project Element を選
択するか、または project editor のﾂｰﾙﾊﾞｰの Add Project Element ﾎﾞﾀﾝをｸﾘｯｸ
します。 Edit Element ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが画面に表示されます。 Browse ｳｨﾝﾄﾞｳ
が表示されて、ﾈｯﾄﾜｰｸに含みたいﾃﾞｰﾀﾌｧｲﾙを選択できます。いったんこ
のﾌﾟﾛｼﾞｪｸﾄﾌｧｲﾙが読み込まれると、 Edit Element ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示され
て、ﾎﾟｰﾄに対してﾈｯﾄﾘｽﾄﾉｰﾄﾞ番号を定義することができます。ﾌﾟﾛｼﾞｪｸﾄ
にﾊﾟﾗﾒｰﾀが含まれている場合は、ここでそれらに対して値を入力するこ
とになります。ﾊﾟﾗﾒｰﾀがﾈｯﾄﾘｽﾄで定義されている場合は、１つのﾊﾟﾗﾒｰﾀ
がﾓﾃﾞﾘﾝｸﾞされる要素の値として入力されます。この機能は 2つの異な
るﾌﾟﾛｼﾞｪｸﾄから得た 2つのﾊﾟﾗﾒｰﾀに強制的に同じ値を使用させる時に使
うことができます。

Adding Parameters

ﾊﾟﾗﾒｰﾀｽｨｰﾌﾟやｵﾌﾟﾃｨﾏｲｾﾞｰｼｮﾝを実行するために、ﾊﾟﾗﾒｰﾀをﾈｯﾄﾘｽﾄに追加
したい場合は、 project editorのﾒｲﾝﾒﾆｭｰから Circuit ⇒ Parametersを選択し
ます。 Parameters ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示され、ﾕｰｻﾞが作成したい各ﾊﾟﾗﾒｰﾀに
対して、ﾊﾟﾗﾒｰﾀ名と名目値を入力することができます。いったんﾊﾟﾗﾒｰﾀ
がﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄに存在すると、そのﾊﾟﾗﾒｰﾀは、ﾈｯﾄﾘｽﾄ要素の１つの
ﾊﾟﾗﾒｰﾀの値として入力することができます。

TIP
I ﾈｯﾄﾘｽﾄのｻﾌﾞﾌﾟﾛｼﾞｪｸﾄにﾊﾟﾗﾒｰﾀを追加する場合は、そのﾊﾟﾗﾒｰﾀは、
ﾈｯﾄﾘｽﾄに自動的には表示されません。ﾒｲﾝﾈｯﾄﾘｽﾄを保存し、それを再び
ｵｰﾌﾟﾝしてそのﾊﾟﾗﾒｰﾀを表示し、編集できるようにする必要があります。
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Netlist Example Files

この章で使用される例題ﾌｧｲﾙのすべては、 Sonnet の例題の Attの例題の
中に入っています。そのﾌｫﾙﾀﾞｰ全体を、例題を実行したい
ﾜｰｷﾝｸﾞﾃﾞｨﾚｸﾄﾘの中にｺﾋﾟｰしてください。Sonnet の例題の入手方法につ
いては、いずれかの Sonnetのﾌﾟﾛｸﾞﾗﾑﾒﾆｭｰから Help ⇒ Examples を選択し、続
いて Instructions ﾎﾞﾀﾝをｸﾘｯｸします。

Cascading S-, Y- and Z-Parameter Data Files
ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄに備えられた機能の中で特に便利なものは、複数の S、
Y、 Z ﾊﾟﾗ ﾒｰﾀのﾃﾞｰﾀﾌｧｲﾙを縦続接続できることです。縦続接続できる
ﾃﾞｰﾀﾌｫｰﾏｯﾄには何の制約もありません。例えば、emで求めた Touchstone
ﾌｫｰﾏｯﾄのZﾊﾟﾗﾒｰ ﾀﾃﾞｰﾀを測定された Super-CompactﾌｫｰﾏｯﾄのSﾊﾟﾗﾒｰﾀﾃﾞｰﾀ
と縦続接続できます。更に、emはﾃﾞｰﾀﾌｧｲﾙにはない周波数点で解析する
ことができます。Emは必要とされる周波数とﾃﾞｰﾀﾌｧｲﾙの中の周波数とに
違いがあると、自動的に補間します。

縦続接続の手順を示すよい例題に、ﾌﾟﾛｼﾞｪｸﾄ att_cascade.sonが用意され
ています。これは、この章の  Att の例題の中に含まれています。2 ﾎﾟｰﾄの
ついた回路を以下に図示しています。この回路は直列に接続されている
2つの同じ薄膜抵抗から構成されています。ここでは、薄膜抵抗の図形
ﾌｧｲﾙの解析によって算出された S ﾊﾟﾗﾒｰﾀが、ﾈｯﾄﾘｽﾄのﾃﾞｰﾀﾌｧｲﾙ要素とし
て使用されます。ﾃﾞｰﾀﾌｧｲﾙを生成するために使用される S ﾊﾟﾗﾒｰﾀﾃﾞｰﾀ
ﾌｧｲﾙである att_res16.s2pと、図形ﾌﾟﾛｼﾞｪｸﾄである att_res16.sonがこの章
の例題に含まれています。

S-parameter
file“att_res16.s2p”

Node 2 Node 3Node 1

ﾌｧｲﾙ “att_res16.s2p”に含まれた 2 ﾎﾟｰﾄの S ﾊﾟﾗﾒｰﾀが縦続接続さ
れて 2 ﾎﾟｰﾄの S ﾊﾟﾗﾒｰﾀを全部合算した値を算出します。

1 2S-parameter
file“att_res16.s2p”
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回路のﾈｯﾄﾘｽﾄ att_cascade.sonを以下に示します。

ﾒｲﾝﾈｯﾄﾜｰｸの Resnetは DEF2Pの “2”で示される 2つのﾎﾟｰﾄを持っていま
す。このﾈｯﾄﾜｰｸでは、ﾎﾟｰﾄ 1はﾉｰﾄﾞ 1に対応します。ﾎﾟｰﾄ 2はﾉｰﾄﾞ 3に対
応します。このﾈｯﾄﾜｰｸには、2つのﾃﾞｰﾀﾌｧｲﾙ要素があります。１つめの
入力は、2 ﾎﾟｰﾄのある応答ﾌｧｲﾙ att_res16.s2pです。ﾎﾟｰﾄ 1はﾈｯﾄﾜｰｸのﾉｰﾄﾞ
1に対応し、これは前述のように回路全体のﾎﾟｰﾄです。ﾃﾞｰﾀﾌｧｲﾙのﾎﾟｰﾄ 2
はこのﾈｯﾄﾜｰｸのﾉｰﾄﾞ 2に対応します。もう１つの入力もまた、ﾃﾞｰﾀﾌｧｲﾙ
att_res16.s2pのためのものですが、ﾃﾞｰﾀﾌｧｲﾙのﾎﾟｰﾄ 1がﾈｯﾄﾜｰｸのﾉｰﾄﾞ 2に
向かっていることが異なります。このことは、2つめのﾃﾞｰﾀﾌｧｲﾙのﾎﾟｰﾄ
1が 1つめのﾃﾞｰﾀﾌｧｲﾙのﾎﾟｰﾄ 2と接続していることを意味します。2つめの
ﾃﾞｰﾀﾌｧｲﾙのﾎﾟｰﾄ 2は、ﾈｯﾄﾜｰｸのﾉｰﾄﾞ 3に対応します。ﾈｯﾄﾜｰｸのﾉｰﾄﾞ 3は、
ﾈｯﾄﾜｰｸはﾈｯﾄﾜｰｸ “RESNET”のﾎﾟｰﾄ 2です。

ﾈｯﾄﾘｽﾄの解析のための S ﾊﾟﾗﾒｰﾀを以下に示します。

Frequency:  200 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
200.000000 0.250782 -5.309 0.748778 -6.263 0.748778 -6.263 0.250782 -5.309

Frequency:  300 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
300.000000 0.250310 -7.963 0.748702 -9.395 0.748702 -9.395 0.250310 -7.963

Frequency:  400 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
400.000000 0.249650 -10.62 0.748595 -12.53 0.748595 -12.53 0.249650 -10.62
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A Network File with Geometry Project
次の例では前につくられたﾃﾞｰﾀを使うとともに、図形ﾌｧｲﾙの解析を開始
させるﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄの解析を説明します。

図形ﾌﾟﾛｼﾞｪｸﾄのあるﾈｯﾄﾘｽﾄの解析を説明するために、以下のような
2 ﾎﾟｰﾄの T型ｱｯﾃﾈｰﾀを解析してみましょう。

S-parameter
file “att_res16.s2p”1 2

geometry project
“att_res67.son”

Node 1 Node 2 Node 3

Emによる電磁界解析と回路解析を組み合わせた解析を説明するために 2 ﾎﾟｰﾄ
の T型ｱｯﾃﾈｰﾀが解析されます。

S-parameter
file “att_res16.s2p”
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下図は 67 ｵｰﾑの薄膜抵抗の図形ﾌﾟﾛｼﾞｪｸﾄ “att_res67.son”で、これは emに
よって読み込まれ、ﾈｯﾄﾘｽﾄの解析中に解析されます。このﾌﾟﾛｼﾞｪｸﾄの解
析結果がﾈｯﾄﾘｽﾄのための結果を計算するために使用されます。

ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄ att_combine.son を以下に示します。ﾌﾟﾛｼﾞｪｸﾄ
att_combine.son はこの章の Att の例題の一部として使えます。

上図のﾈｯﾄﾘｽﾄとその前のﾈｯﾄﾘｽﾄとの大きな違いは、このﾈｯﾄﾘｽﾄは
ﾌﾟﾛｼﾞｪｸﾄの解析を行うという指示を含んでいるということです。PRJ
ｷｰﾜｰﾄﾞは emにﾈｯﾄﾘｽﾄからの解析ｺﾝﾄﾛｰﾙ を使ってﾌﾟﾛｼﾞｪｸﾄ  “att_res67　
.son” 上で電磁界解析を実行するように指示しています。解析ｺﾝﾄﾛｰﾙの使
用は、 PRJ ｽﾃｰﾄﾒﾝﾄの中で “Hierarchy Sweep”によって指示されています。
ｺﾝﾄﾛｰﾙが “Hierarchy Sweep”に設定されると、emは自動的にｻﾌﾞﾌﾟﾛｼﾞｪｸﾄ
をﾈｯﾄﾘｽﾄと同じ周波数ｽｨｰﾌﾟと実行ｵﾌﾟｼｮﾝで解析します。

Transmission
Line

Transmission
Line

67 ohm
Thin-Film
Resistor
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解析中、emは次のｽﾃｯﾌﾟで進みます。

1 “att_res16.s2p” ﾌｧｲﾙから S ﾊﾟﾗﾒｰﾀのﾃﾞｰﾀを読み込みます。

2 67 ｵｰﾑの薄膜抵抗の図形ﾌﾟﾛｼﾞｪｸﾄ “att_res67.son”を電磁界解析し
ます。

3 電磁界解析から得た S ﾊﾟﾗﾒｰﾀの結果と “att_res16.s2p”からの
Sﾊﾟﾗﾒｰﾀの結果を合わせてT型ｱｯﾃﾈｰﾀのSﾊﾟﾗﾒｰﾀを合算した値を算
出します。

TIP
PRJ に書かれていることを実行する前に、emは設定されたｺﾝﾄﾛｰﾙ周波数
にﾃﾞｰﾀがあるかどうか確認します。そのﾃﾞｰﾀが既に存在していて、その
ﾃﾞｰﾀが作成されてからﾌﾟﾛｼﾞｪｸﾄ が変わっていなければ、emは電磁界解
析は行ないませんが、その有効なﾃﾞｰﾀは使います。

以下のﾘｽﾄはﾈｯﾄﾘｽﾄの解析の出力です。解析ﾓﾆﾀｰに表示された様子を示
しています。これには T型ｱｯﾃﾈｰﾀの S ﾊﾟﾗﾒｰﾀのすべてが入っています。

Frequency:  200 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
200.000000 0.008924 67.700 0.500516 -5.758 0.500516 -5.758 0.008924 67.700

Frequency:  300 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
300.000000 0.013072 68.918 0.501160 -8.647 0.501160 -8.647 0.013072 68.918

Frequency:  400 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
400.000000 0.017177 67.763 0.502055 -11.54 0.502055 -11.54 0.017177 67.763
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Inserting Modeled Elements into a Geometry 
ﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄがご提供するもう１つの大変便利な点は、回路で電磁界
解析が完了した後で、ﾓﾃﾞﾘﾝｸﾞされる要素を図形ﾌﾟﾛｼﾞｪｸﾄの中に挿入す
ることができることです。ﾓﾃﾞﾘﾝｸﾞされる要素とは、抵抗、ｲﾝﾀﾞｸﾀ、
ｷｬﾊﾟｼﾀ、伝送線路などの理想的な素子で、それだけで簡潔した解析値を
持っています。これらのﾓﾃﾞﾘﾝｸﾞされる要素は電磁界解析を行いません。

ﾓﾃﾞﾘﾝｸﾞされる要素の使い方を説明するために、再び T型ｱｯﾃﾈｰﾀを解析
してみましょう。しかし、この章の前で示したように、この ｱｯﾃﾈｰﾀは、
電磁界解析の結果をむすびつけて得た結果ではなく、この場合、図形
ﾌﾟﾛｼﾞｪｸﾄ att_lgeo.sonには、ﾓﾃﾞﾘﾝｸﾞされる要素を挿入する必要がある場
合に、完全なｱｯﾃﾈｰﾀを切り出したﾓﾃﾞﾙそのものが用意されています。3
つの抵抗は図形ﾌﾟﾛｼﾞｪｸﾄの一部として解析されませんが、ﾈｯﾄﾘｽﾄの中で
ﾓﾃﾞﾘﾝｸﾞされる要素として挿入されます。次の図はﾓﾃﾞﾘﾝｸﾞされる要素を
持つ回路のﾚｲｱｳﾄです。伝送線路で構成されている図形ﾌﾟﾛｼﾞｪｸﾄが最初
に生成されます。次に 3つの抵抗を挿入し、回路全体の 2 ﾎﾟｰﾄ の
S ﾊﾟﾗﾒｰﾀを計算するためにﾈｯﾄﾘｽﾄﾌﾟﾛｼﾞｪｸﾄが使われます。

これを行なうためには、伝送線路の構造体と後にﾓﾃﾞﾘﾝｸﾞされる要素が
挿入される 3つの “穴 ”を持つ図形ﾌﾟﾛｼﾞｪｸﾄを作成する必要がありま
す。196 ﾍﾟｰｼﾞの図はそのような図形ﾌﾟﾛｼﾞｪｸﾄです。ここでは、組になっ
た auto-grounded ﾎﾟｰﾄが各々のﾓﾃﾞﾘﾝｸﾞされる要素が入る “穴 ”の両端に
設置されています。後でﾓﾃﾞﾘﾝｸﾞされる要素が挿入されると、対応する
組の auto-grounded ﾎﾟｰﾄの間に各々のﾓﾃﾞﾘﾝｸﾞされる要素がつながります。
ある条件下では、ungrounded-internal ﾎﾟｰﾄが auto-grounded ﾎﾟｰﾄの代わりに
使うことができます。詳しくは 197 ﾍﾟｰｼﾞの “Using Ungrounded-Internal 
Ports”をご覧ください。
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metalization

2 ﾎﾟｰﾄの T型ｱｯﾃﾈｰﾀを再び解析して、ﾓﾃﾞﾘﾝｸﾞされる要素
の使い方を説明しています。
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下図はこの例題で使われるﾈｯﾄﾘｽﾄ att_lumped.sonです。

図形ﾌｧｲﾙ “att_lgeo.son”には auto-grounded ﾎﾟｰﾄが 3組あります。このﾎﾟｰﾄは
後でﾓﾃﾞﾘﾝｸﾞされる要素が置かれる場所に設定されます。このﾌｧｲﾙはこの章
で使用されている Attの例題の一部として入手できます。
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上のﾈｯﾄﾘｽﾄは emに次のｽﾃｯﾌﾟを踏むように指示しています。

1 このﾈｯﾄﾘｽﾄのために定義された Frequency sweepと実行ｵﾌﾟｼｮﾝを用いて、
図形ﾌｧｲﾙ “att_lgeo.son”上で電磁界解析を実行します。 PRJ行に従って、
ﾒｲﾝﾈｯﾄﾜｰｸ attenの中では、ﾎﾟｰﾄ 1-8 はﾉｰﾄﾞ 1-8 にそれぞれ対応している
ことに注目してください。ﾉｰﾄﾞ番号は、回路のﾎﾟｰﾄの順番に、  PRJ 
ｷｰﾜｰﾄﾞの後に列挙されています。

2 ﾉｰﾄﾞ 3 とﾉｰﾄﾞ 4の間に 16.77 ｵｰﾑの抵抗を挿入します。これは図形
ﾌﾟﾛｼﾞｪｸﾄの中に autogrounded ﾎﾟｰﾄ 3と 4 の間に抵抗を挿入したことと同
じです。

3 ﾉｰﾄﾞ 5 とﾉｰﾄﾞ 6の間に 16.77 ｵｰﾑの抵抗を挿入します。

4 ﾉｰﾄﾞ 7 とﾉｰﾄﾞ 8の間に 67.11 ｵｰﾑの抵抗を挿入します。

5 T型ｱｯﾃﾈｰﾀの S ﾊﾟﾗﾒｰﾀを合算します。

2つのﾌﾟﾛｼﾞｪｸﾄ att_lgeo.son と att_lumped.son は、この章の Att の例題から入手する
ことができます。下のﾘｽﾄは解析ﾓﾆﾀｰに表示された時の解析出力です。これらの
結果は分布定数素子で求めた上の結果に類似していることにご注意ください。

Using Ungrounded-Internal Ports

上述の例題では 1組の auto-grounded ﾎﾟｰﾄが emの回路ﾚｲｱｳﾄの中の
ﾓﾃﾞﾘﾝｸﾞされる要素が後で挿入される場所に各々設置されていました。
これは、 ungrounded-internal ﾎﾟｰﾄを使っても同じ解析を行なうことができ
ます。というのは、この例では各抵抗はｸﾞﾗｳﾝﾄﾞに導通しない直列の

Frequency:  200 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
200.000000 0.007889 66.619 0.500390 -4.888 0.500390 -4.888 0.007889 66.619

Frequency:  300 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
300.000000 0.011495 69.396 0.500788 -7.336 0.500788 -7.336 0.011495 69.396

Frequency:  400 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
400.000000 0.015119 69.443 0.501342 -9.787 0.501342 -9.787 0.015119 69.443
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ﾓﾃﾞﾘﾝｸﾞされる要素だからです。ﾓﾃﾞﾘﾝｸﾞされる要素は必ずしもｸﾞﾗｳﾝﾄﾞ
に接している必要はありませんので、１組の auto-grounded ﾎﾟｰﾄを１つの
ungrounded-internal ﾎﾟｰﾄに置き換えることができます。

下図はﾓﾃﾞﾘﾝｸﾞされるﾌﾟﾛｼﾞｪｸﾄのある場所に ungrounded-internal ﾎﾟｰﾄを設
置した T型ｱｯﾃﾈｰﾀの図形ﾌﾟﾛｼﾞｪｸﾄです。これらの場所の図形と図形の間
にｷﾞｬｯﾌﾟがあることに注目してください｡これは、2つの隣接する図形の
間に ungrounded-internal ﾎﾟｰﾄをつけなくてはならないからです。これは、
ｱｯﾃﾈｰﾀの全体の働きに少し影響を与えます。

図形ﾌﾟﾛｼﾞｪｸﾄ “att_lgeo2.son”は、後でﾓﾃﾞﾘﾝｸﾞされる要素が挿入され
る場所に ungrounded-internal ﾎﾟｰﾄを使用します。

Z3
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以下のﾈｯﾄﾜｰｸﾌｧｲﾙは、198 ﾍﾟｰｼﾞにあるﾈｯﾄﾜｰｸの ungrounded-internal ﾎﾟｰﾄ
の間に所望の抵抗をつないだものです。  Ungrounded-internal ﾎﾟｰﾄｸﾞﾗｳﾝﾄﾞ
に接していないので、そのﾎﾟｰﾄの間に素子を１つつなげる時には、１つ
のﾉｰﾄﾞだけが特定されるだけです。

! WARNING
Ungrounded-internal ﾎﾟｰﾄの１つの端子は図形の端に接続されています。
もう１つの端子は隣接しているもう１つの図形の端に接続されていま
す。Ungrounded-internal ﾎﾟｰﾄはｸﾞﾗｳﾝﾄﾞに接している必要はありません。
従って 1 ﾎﾟｰﾄの素子か１ﾎﾟｰﾄのﾈｯﾄﾜｰｸだけが ungrounded-internal ﾎﾟｰﾄの
間に接続されます。抵抗、ｷｬﾊﾟｼﾀ、ｲﾝﾀﾞｸﾀは技術的には、1 ﾎﾟｰﾄの素子
なのでﾈｯﾄﾘｽﾄでは、 ungrounded-internal ﾎﾟｰﾄ の代わりに挿入されます。

この回路のﾈｯﾄﾘｽﾄ att_lumped2.sonを以下に示します。図形ﾌﾟﾛｼﾞｪｸﾄ
att_lgeo2.sonとこのﾈｯﾄﾘｽﾄは、この章に用意されている Attの例題から入
手することができます。

このﾈｯﾄﾘｽﾄで注意すべき重要な特徴は、ﾊﾟﾗﾒｰﾀの使用です。3つの
ﾊﾟﾗﾒｰﾀ Z3、 Z4 、 Z5 がこのﾌﾟﾛｼﾞｪｸﾄでは定義されており、それらの値は 3
つの抵抗のﾓﾃﾞﾘﾝｸﾞされる要素に使用されました。ﾊﾟﾗﾒｰﾀはﾒｲﾝﾒﾆｭｰから
Circuit ⇒ Parameters を選択し、表示された Parameters ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの中
に、ﾊﾟﾗﾒｰﾀ名と名目値を入力することによって、ﾈｯﾄﾘｽﾄの中に定義され
ます。Z3と Z4は、 16.77と等しく、Z5は、 67.11に等しいです。
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下のﾘｽﾄは ungrounded-internal ﾎﾟｰﾄで解析した S ﾊﾟﾗﾒｰﾀの結果です。これ
らの結果は auto-grounded ﾎﾟｰﾄで解析した結果と、非常によく似ています
が、全く同じものではありません。主な違いは集中定数素子が挿入され
る場所の図形と図形の間のｷﾞｬｯﾌﾟの大きさによるものです。

Frequency:  200 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
200.000000 0.009217 68.496 0.500482 -5.785 0.500482 -5.785 0.009217 68.496

Frequency:  300 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
300.000000 0.013510 70.114 0.500994 -8.683 0.500994 -8.683 0.013510 70.114

Frequency:  400 MHz
50-Ohm S-Params. Mag/Ang. Touchstone Format. (S11 S21 S12 S22).
400.000000 0.017788 69.364 0.501707 -11.59 0.501707 -11.59 0.017788 69.364


