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Chapter 6 Ports

この章では Sonnetで使用される 4つの異なる種類のﾎﾟｰﾄについてを説明
し、また、そのﾎﾟｰﾄのﾓﾃﾞﾘﾝｸﾞ方法、そしてﾕｰｻﾞの回路へどのように設
定し、削除するのかを説明します。

Sonnetで使用される 4つの種類のﾎﾟｰﾄは、標準 box-wall ﾎﾟｰﾄ、 ungrounded-
internal ﾎﾟｰﾄ、 via ﾎﾟｰﾄ、auto-grounded ﾎﾟｰﾄです。

Port Types
Sonnetで扱うすべてのﾎﾟｰﾄは 2端子のﾃﾞﾊﾞｲｽです。ﾎﾟｰﾄの種類の違いはど
こに端子が接続されるかです。

最もよく使用される種類のﾎﾟｰﾄは標準 box-wall ﾎﾟｰﾄで、１つめの端子が
金属の図形に置かれ、2つめの端子が box wall( ｸﾞﾗｳﾝﾄﾞ ) に置かれます。
この種類のﾎﾟｰﾄは emでﾃﾞｨｴﾝﾍﾞｯﾄﾞすることが可能です。
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しかし、時々 2つの隣接する図形の間に１つのﾎﾟｰﾄの 2つの端子を取り
つけると便利です。これは ungrounded-internal ﾎﾟｰﾄです。この種類の
ﾎﾟｰﾄは emではﾃﾞｨｴﾝﾍﾞｯﾄﾞできません。複数ﾎﾟｰﾄの回路で S、Y、Z の
ﾊﾟﾗﾒｰﾀを調べる解析では、回路内のﾎﾟｰﾄは通常すべてｸﾞﾗｳﾝﾄﾞされてい
ます。ｸﾞﾗｳﾝﾄﾞされていないﾎﾟｰﾄは、回路内の他のﾎﾟｰﾄとは違う参照面
を持つことができますので解析結果が正しくなくなることもあります。

3つめの種類のﾎﾟｰﾄは viaﾎﾟｰﾄです。 Viaﾎﾟｰﾄは回路のあるﾚﾍﾞﾙの上に描か
れた図形に接続された１つの端子と、その図形の上の回路基板上のもう
１つの図形に接続された端子からなります。Emは via ﾎﾟｰﾄを
ﾃﾞｨｴﾝﾍﾞｯﾄﾞできません。Via ﾎﾟｰﾄは、回路の中で隣接する 2つのﾚﾍﾞﾙの
間にﾎﾟｰﾄを取りつけたい時や、ﾎﾟｰﾄをｸﾞﾗｳﾝﾄﾞの下よりもﾎﾞｯｸｽの天頂へ
上向きにつけたい時に最もよく使われるﾎﾟｰﾄです。

最後の種類のﾎﾟｰﾄは auto-grounded ﾎﾟｰﾄです。Auto-grounded ﾎﾟｰﾄは、回路
の内側で使用され、金属図形の端に接続している端子と、間にあるすべ
ての誘電体層を通ってｸﾞﾗｳﾝﾄﾞ面に接続している端子から成っています。
Emは auto-grounded ﾎﾟｰﾄをﾃﾞｨｴﾝﾍﾞｯﾄﾞすることができます。Auto-
grounded ﾎﾟｰﾄについての詳細と使用上の制限については、112 ﾍﾟｰｼﾞの
“Automatic-Grounded Ports”をご覧ください。

どの種類のﾎﾟｰﾄも斜め線上には置くことができません。お互いに重なり
合うこともできません (接触することは許されています )。解析ｴﾝｼﾞﾝは
これらのｴﾗｰの条件をﾃｽﾄしています。

ﾎﾟｰﾄの各種類についてと、すべてのﾎﾟｰﾄの種類に関する事柄 (例えば
ﾎﾟｰﾄのﾅﾝﾊﾞﾘﾝｸﾞやｲﾝﾋﾟｰﾀﾞﾝｽなど )が次の節で詳細に説明されています。
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Standard Box-Wall Ports
標準 box-wall ﾎﾟｰﾄはｸﾞﾗｳﾝﾄﾞ･ﾎﾟｰﾄです。１つの端子はﾎﾞｯｸｽの壁と一致
する図形の端に接しており、もう１つの端子はｸﾞﾗｳﾝﾄﾞに接しています。
標準 box-wall ﾎﾟｰﾄを下図に示します。標準 box-wall ﾎﾟｰﾄはﾃﾞｨｴﾝﾍﾞｯﾄﾞで
きます。

Adding Standard Ports
1 回路に標準のﾎﾟｰﾄを追加するために、ﾂｰﾙﾎﾞｯｸｽの Add Port ﾎﾞﾀﾝ、

または project editorのﾒｲﾝﾒﾆｭｰから Tools ⇒ Add Port を選択しま
す。

2 ﾎﾟｰﾄを追加したい位置の図形のｴｯｼﾞの上でｸﾘｯｸしてください。
中央に数字のついた小さなﾎﾞｯｸｽが回路上に現れ、ﾎﾟｰﾄの位置を
示します。

ﾎﾟｰﾄは回路上で指定した順に自動的に番号がつきます。後でﾎﾟｰﾄの番号
を変えることができます。この操作は後で述べます。詳細は、103 ﾍﾟｰｼﾞ
の “Changing Port Numbering”をご覧ください。

1
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Special Port Numbering
すべてのﾎﾟｰﾄは project editorで作成された時に番号をつけられています。
ﾎﾟｰﾄ数には制限がありません。また、ﾎﾟｰﾄ数は解析時間にはまったく影
響を与えません。ﾃﾞﾌｫﾙﾄではﾎﾟｰﾄは作成された順に番号をつけられます
(最初に作成されたﾎﾟｰﾄは 1という番号がつけられ、 2番めに作成された
ﾎﾟｰﾄは 2という番号がつけられます）。このﾃﾞﾌｫﾙﾄ設定による方法では、
すべてのﾎﾟｰﾄには、正の番号がつけられ、番号は１回しか使われませ
ん。しかし、同じ番号を持つ複数のﾎﾟｰﾄや負の番号のﾎﾟｰﾄを必要とする
ｱﾌﾟﾘｹｰｼｮﾝもあります。

Ports with Duplicate Numbers

同じ番号のついたﾎﾟｰﾄはみな、電気的に接続されています (下図参照）。
実際のﾎﾟｰﾄは必要なだけいくらでも同じ数字のﾗﾍﾞﾙを与えることができ
ます。このようなﾎﾟｰﾄは時々、 “even-mode” ﾎﾟｰﾄとか、“push-push” ﾎﾟｰﾄと
呼ばれ、薄い金属導体のｼﾐｭﾚｰｼｮﾝや、回路の even-modeの応答など多く
の用途があります。“push-push” ﾎﾟｰﾄの使い方の例は、“Modeling an 
Arbitrary Cross-Section” をご覧ください。

Ports with Negative Numbers

ﾎﾟｰﾄには負の番号を割り当てることもできます (103 ﾍﾟｰｼﾞの図参照 )。こ
の機能はｸﾞﾗｳﾝ ﾄﾞ平面の再定義に用います。厳密にいえば、emは同じ正
のﾎﾟｰﾄ番号を持つすべてのﾎﾟｰﾄに流れる電流の総和をとり、同じ負の
ﾎﾟｰﾄ番号を持つすべてのﾎﾟｰﾄから出る総電流に等しくなるように設定し

同一番号のﾎﾟｰﾄは
電気的に接続され
ています。
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ます。例えば、 +1 ﾎﾟｰﾄと -1 ﾎﾟｰﾄがある回路を仮定した時、emはﾎﾟｰﾄ -1か
ら流れ出る電流に等しいようにﾎﾟｰﾄ +1に流れる電流を設定します。従っ
て、これには “balanced( 平衡）”とか、“push-pull” 、または “odd-mode”
ﾎﾟｰﾄという名前がつけられています｡共平面線路は、この平衡ﾎﾟｰﾄを用
いて表現することができます。push-pull ﾎﾟｰﾄについては、第 23章の
“Coplanar Waveguide and Balanced Ports”  をご覧ください。

ﾎﾟｰﾄの番号は連続している必要はありません。すなわち 2つしかﾎﾟｰﾄがない場
合、一方が “1”でもう片方が “4”であってもかまいません。S、Y、 Z ﾊﾟﾗﾒｰﾀの
ﾎﾟｰﾄ番号の並びは番号の順に並べられます。例えば、ﾎﾟｰﾄ番号が “1”と “4”の時
には、 S11, S41, S14, S44となります。

Changing Port Numbering
1 番号を変えたいﾎﾟｰﾄの上をｸﾘｯｸします。Modify ﾒﾆｭｰｵﾌﾟｼｮﾝが使

えるようになります。

2 Modify ⇒ Port Properties を選択するとPort Attributes ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽ
が表示されます。

3 ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの中の Number 入力ﾎﾞｯｸｽ内に所望する数字を入力
するとﾎﾟｰﾄの番号は変えられます。入力する番号は 0でない整
数 (正、負 )です。複数のﾎﾟｰﾄが選ばれていると、Number入力
ﾎﾞｯｸｽ内に、“Mixed”が現れます。このﾌｨｰﾙﾄﾞに数字を入れると、
選ばれたすべてのﾎﾟｰﾄに同じ番号をつけることができます。

push-pull ﾎﾟｰﾄの例
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Port Normalizing Impedances
回路解析ﾌﾟﾛｸﾞﾗﾑをもとにした回路理論で結果がまとめられていれば常
に各ﾎﾟｰﾄにおいて正規化されたｲﾝﾋﾟｰﾀﾞﾝｽは 50 ｵｰﾑでなければなりませ
ん。稀に別のｲﾝﾋﾟｰﾀﾞﾝｽで正規化された S ﾊﾟﾗﾒｰﾀが必要な場合がありま
す。

例えばﾎﾟｰﾄ 2に 10 ｵｰﾑの抵抗と 1.0 pFのｺﾝﾃﾞﾝｻを並列接続し ( ﾊﾟﾜｰ FET
の入力ﾓﾃﾞﾙ )、内部ｲﾝﾋﾟｰﾀﾞﾝｽ 35 ｵｰﾑ のｿｰｽを動作させて、反射係数を求め
たいとします。この場合、ﾎﾟｰﾄ 1 は 35 ｵｰﾑ に、ﾎﾟｰﾄ 2は 10 ｵｰﾑと 1.0pFの
合成ｲﾝﾋﾟｰ ﾀﾞﾝｽに正規化します。

純粋な電磁気学ではよくそれぞれの接続部分の線路の特性ｲﾝﾋﾟｰﾀﾞﾝｽに
正規化された S ﾊﾟﾗﾒｰﾀが用いられます。これらはよく “一般化 ”S ﾊﾟﾗﾒｰﾀ
と呼ばれてはいますが、常に線路ｲﾝﾋﾟｰﾀﾞﾝｽが特定されているわけでも
なく、従って回路理論ｿﾌﾄを使う上で、50 ｵｰﾑに正確に変換できません。

正規化 S ﾊﾟﾗﾒｰﾀの物理的意味を理解するためには、標準 50S ﾊﾟﾗﾒｰﾀとい
うのは、すべてのﾎﾟｰﾄを 50 ｵｰﾑで終端した回路の、反射された (または、
伝送された )波の振幅の比を測定したものであることをもう一度思い出
してみてください。もし 50 ｵｰﾑの代わりに、60 ｵｰﾑの終端を用いたら、
60 ｵｰﾑに正規化された S ﾊﾟﾗﾒｰﾀが、進行波の割合を測定することによって
求められるでしょう。それからその 60 ｵｰﾑで終端された回路の測定に
よって求めた S ﾊﾟﾗﾒｰﾀを、(50 ｵｰﾑで終端されたものを使うことが前提の )
回路理論ﾌﾟﾛｸﾞﾗﾑに用いたとすれば、間違った結果を得るでしょう。

しかしながら、60 ｵｰﾑの S ﾊﾟﾗﾒｰﾀを使う場合もあります。2 ﾎﾟｰﾄ回路の
60 ｵｰﾑで終端されているﾎﾟｰﾄ 2で吸収される電力を求めたいとします。こ
れは単に、60 ｵｰﾑの S ﾊﾟﾗﾒｰﾀを用いて、1から S11の大きさの 2乗を引け
ばよいのです。もし他の違う負荷でしたい場合はその負荷に正規化され
たｲﾝﾋﾟｰﾀﾞﾝｽをご使用ください。
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S ﾊﾟﾗﾒｰﾀは、各ﾎﾟｰﾄに適切な変成器を縦続接続し、emの回路ﾈｯﾄﾜｰｸ機能
や回路理論をもとにしたﾌﾟﾛｸﾞﾗﾑによって、どんなｲﾝﾋﾟｰﾀﾞﾝｽにも再正規
化できます。しかし、この技法は線路に損失があったり、負荷が複素数
であるなど、ｲﾝﾋﾟｰﾀﾞﾝｽが複素数となる場合は使用できません。

Emにおいて、ﾃﾞﾌｫﾙﾄの正規化ｲﾝﾋﾟｰﾀﾞﾝｽは 50 ｵｰﾑです。もし違う正規化をする場
合は、106 ﾍﾟｰｼﾞの “Changing Port Impedance” で、各ﾎﾟｰﾄの正規化ｲﾝﾋﾟｰﾀﾞﾝｽ
をどのように設定するかを参照してください。

正規化ｲﾝﾋﾟｰﾀﾞﾝｽは 4つの数により決まります。1つめはｵｰﾑの実部、次
はｵｰﾑの虚部、3つめは nHで示されるｲﾝﾀﾞｸﾀﾝｽ成分、最後は pFで示さ
れるｷｬﾊﾟｼ ﾀﾝｽ成分です。ｲﾝﾀﾞｸﾀﾝｽとｷｬﾊﾟｼﾀﾝｽ成分は、負荷のﾘｱｸﾀﾝｽ成分
を変化させるだけで、その中に含まれてしまいますので、わざわざもう
一度各周波数において、ﾘｱｸﾀﾝｽ成分を計算し直す必要はありません。

抵抗、ﾘｱｸﾀﾝｽ、ｲﾝﾀﾞｸﾀﾝｽは各解析周波数で特定の正規化ｲﾝﾋﾟｰﾀﾞﾝｽを計
算する時、直列に接続されます (下図参照 )。ｷｬﾊﾟｼﾀﾝｽはその結果に並
列接続され、解析周波数において最後の正規化ｲﾝﾋﾟｰﾀﾞﾝｽが計算されま
す。

V

R + jX L

C

Equivalent circuit of an em port
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NOTE: 出力に Y ﾊﾟﾗﾒｰﾀや Z ﾊﾟﾗﾒｰﾀが指定された場合、正規化ｲﾝﾋﾟｰﾀﾞﾝｽは無視さ
れます。Y ﾊﾟﾗﾒｰﾀと Z ﾊﾟﾗﾒｰﾀはいつも１ｵｰﾑに正規化されます。

この機能は、ほとんど熟練したﾕｰｻﾞだけが使うべきです。以上の内容が
不明な場合は、わかる方を捜してください。どのような場合でも、
Sonnet以外の標準的な回路理論ﾌﾟﾛｸﾞﾗﾑの中で用いられるﾃﾞｰﾀに、この機
能を使うべきではありません。というのも、多くのそのようなﾌﾟﾛｸﾞﾗﾑ
においては、S ﾊﾟﾗﾒｰﾀが正確に 50 ｵｰﾑに正規化されていると仮定されてい
るからです。

例えば、ﾏｲｸﾛｽﾄﾘｯﾌﾟ回路のｽﾃｯﾌﾟ接合部における 50 ｵｰﾑの S ﾊﾟﾗﾒｰﾀは、非
常に小さいｼｬﾝﾄｷｬﾊﾟｼﾀﾝｽと直列ｲﾝﾀﾞｸﾀﾝｽがあるかのように求められま
す。言い換えますと、反射係数はほとんど 0で、伝達係数はほぼ 1で、
位相角も 1～ 2度です。もし 50 ｵｰﾑの S ﾊﾟﾗﾒｰﾀの代わりに、2 ﾎﾟｰﾄに接続
している線路の特性ｲﾝﾋﾟｰﾀﾞﾝｽに正規化された S ﾊﾟﾗﾒｰﾀを用いると(電磁
気学では一般的ですが )、S ﾊﾟﾗﾒｰﾀは 2つのｲﾝﾋﾟｰﾀﾞﾝｽ変換器のようにな
ります。これにより、50 ｵｰﾑ S ﾊﾟﾗﾒｰﾀを前提としている多くの回路理論
ﾌﾟﾛｸﾞﾗﾑを用いると、大きく違う結果になってしまいます。

Changing Port Impedance

ﾎﾟｰﾄのｲﾝﾋﾟｰﾀﾞﾝｽを変更するには 2つの方法があります。１つのﾎﾟｰﾄのｲﾝﾋﾟｰﾀﾞﾝｽ
を変えたいが、他のﾎﾟｰﾄのｲﾝﾋﾟｰﾀﾞﾝｽ値は変えたくない場合は、project editorを
使って次のｽﾃｯﾌﾟを踏んでください。

1 ｲﾝﾋﾟｰﾀﾞﾝｽを変えたいﾎﾟｰﾄの上をｸﾘｯｸすると、 Modify ﾒﾆｭｰｵﾌﾟｼｮﾝ
が使えるようになります。

2 Modify ⇒ Port Propertiesを選択して Port Attributes ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを
ｵｰﾌﾟﾝします。

3 ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの中の Resistance、Reactance、Inductance、Capaci-
tance入力ﾎﾞｯｸｽに、所望する値を入力するとｲﾝﾋﾟｰﾀﾞﾝｽの値を変えるこ
とができます。選択されたすべてのﾎﾟｰﾄとそれと同じ番号を持つすべて
のﾎﾟｰﾄ上のﾊﾟﾗﾒｰﾀが変わります。
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もし与えられたﾎﾟｰﾄのｲﾝﾋﾟｰﾀﾞﾝｽを変えたくて、しかも同時に他のﾎﾟｰﾄのｲﾝﾋﾟｰ　
ﾀﾞﾝｽ値を見たいなら、次のように行います。

1 ﾒｲﾝﾒﾆｭｰから Circuit ⇒ Ports を選択し、 Port Impedance 
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽをｵｰﾌﾟﾝします。

2 所望するﾎﾟｰﾄの番号と同じ入力列の Resistance、 Reactance、
Inductance、Capacitanceの入力ﾎﾞｯｸｽに所望する値を入力すれば
どんなﾎﾟｰﾄのｲﾝﾋﾟｰﾀﾞﾝｽ値も変えることができます。

TIP
複数のﾎﾟｰﾄのｲﾝﾋﾟｰﾀﾞﾝｽは、 Modify ⇒ Attributesを選択する前に、複数の
ﾎﾟｰﾄを選択するという１番めの方法で同時に変えられることに気をつけ
てください。そして 2番めの Port Impedance ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽがｵｰﾌﾟﾝしてい
る時に所望するﾎﾟｰﾄの値のすべてを変える方法もあります。

 Defining Reference Planes/Calibration Lengths
参照面とｷｬﾘﾌﾞﾚｰｼｮﾝ長は互いに独立しているものですがすべての種類の
ﾎﾟｰﾄで指定することができます。しかし、ﾎﾟｰﾄの種類によって方法が異
なります。参照面は emでﾃﾞｨｴﾝﾍﾞｯﾄﾞできない via ﾎﾟｰﾄでは指定できませ
ん。Ungrounded-internal ﾎﾟｰﾄでは、どのﾎﾞｯｸｽ壁が参照されているのか不
確かなので参照面は指定できません。標準ﾎﾟｰﾄと auto-grounded ﾎﾟｰﾄの方
法を以下で詳しく説明します。

Standard Ports

標準ﾎﾟｰﾄは大抵ﾎﾞｯｸｽの壁面上に存在しますので参照面またはｷｬﾘﾌﾞﾚｰ　
ｼｮﾝ長はﾎﾞｯｸｽの壁面までの距離のことです。参照面またはｷｬﾘﾌﾞﾚｰｼｮﾝ長
を指定するには次のように行います。
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1 ﾒｲﾝﾒﾆｭｰから Circuit ⇒ Ref. Planes/Cal. Lengths を選択すると Reference 
Planes/Calibration Lengths ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽがｵｰﾌﾟﾝします。

2 Box wall ﾘｽﾄの中で参照面かｷｬﾘﾌﾞﾚｰｼｮﾝ長のいずれかを設定したい方向
(Top、Left、Rightまたは Bottom)を選びます。

3 次に参照面のﾀｲﾌﾟである、Linked または Fixedをﾗｼﾞｵﾎﾞﾀﾝから選択しま
す。ｷｬﾘﾌﾞﾚｰｼｮﾝ長を定義したい場合は、 None ﾗｼﾞｵﾎﾞﾀﾝをｸﾘｯｸし、次に
Use fixed cal. length ﾁｪｯｸﾎﾞｯｸｽをｸﾘｯｸします。

4 ﾘﾝｸされた (Linked)参照面を選択する場合は、ﾏｳｽﾎﾞﾀﾝをｸﾘｯｸし、次に参
照面をﾘﾝｸしたい回路内の図形の１点を選びます。固定した (Fixed)参照
面を選択する場合は、ﾃｷｽﾄ入力ﾎﾞｯｸｽの中に長さを入力するか、または
ﾏｳｽﾎﾞﾀﾝをｸﾘｯｸし、回路の距離を設定します。ｷｬﾘﾌﾞﾚｰｼｮﾝ長を定義して
いる場合は、ﾃｷｽﾄ入力ﾎﾞｯｸｽの中に所望する長さを入力します。

5 参照面またはｷｬﾘﾌﾞﾚｰｼｮﾝ長を除去するには、 None ﾗｼﾞｵﾎﾞﾀﾝをｸﾘｯｸし、
Use fixed cal. lengthにはﾁｪｯｸﾏｰｸを入れません。ﾎﾞｯｸｽの同じ側のすべて
のﾚﾍﾞﾙのすべてのﾎﾟｰﾄには同じ参照面か ｷｬﾘﾌﾞﾚｰｼｮﾝ長のいずれかが使
用されています。



Chapter 6  Ports

109

Auto-ground Ports

Auto-grounded ﾎﾟｰﾄでは、参照面またはｷｬﾘﾌﾞﾚｰｼｮﾝ長がある特定のﾎﾟｰﾄか
らの距離として定義されます。 Auto-grounded ﾎﾟｰﾄで参照面はまたはｷｬ　
ﾘﾌﾞﾚｰｼｮﾝ長を指定するには、次のように行います。

1 設定したいﾎﾟｰﾄをｸﾘｯｸすると、Modify ﾒﾆｭｰｵﾌﾟｼｮﾝが使えるよう
になります。

2 Modify ⇒ Port Attributesを選択すると 115ﾍﾟｰｼﾞの図のような Port 
Attributes ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが表示されます。

3 Autognd Port Dataの枠の Ref. Plane （参照面）か Cal. Length
（ｷｬﾘﾌﾞﾚｰｼｮﾝ長 )のﾌｨｰﾙﾄﾞに所望する長さを入力します。または
Use Mouse ﾎﾞﾀﾝを押し、所望する位置の回路内でｸﾘｯｸすれば参照
面を指定するのにﾏｳｽも使えます。Ref. Plane （参照面）の入力
は選択時に更新されます。

4 参照面またはｷｬﾘﾌﾞﾚｰｼｮﾝ長を除去するために、除去したい
ﾌｨｰﾙﾄﾞ内に０（ｾﾞﾛ）を入力します。

TIP
あるﾎﾟｰﾄを autogroundの種類に変えたり、参照面またはｷｬﾘﾌﾞﾚｰｼｮﾝ長を
設定するには、 Port Attributes ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽ内で指定すると一度にできま
す。または設定したいﾎﾟｰﾄをｾﾚｸﾄし、 Modify ⇒ Port Properties  をﾒﾆｭｰで選
択し、Port Attributes ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽの中でｷｬﾘﾌﾞﾚｰｼｮﾝ長の値を入力すると
複数のﾎﾟｰﾄのｷｬﾘﾌﾞﾚｰｼｮﾝ長を設定することもできます。

Deleting Ports
すべての種類のﾎﾟｰﾄは同じ方法で削除されます。ﾎﾟｰﾄを選び、ﾂｰﾙﾊﾞｰま
たはﾒﾆｭｰから Cut または Delete操作を実行し、回路からﾎﾟｰﾄを削除しま
す。
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Ungrounded-Internal Ports
標準 ungrounded-internal( ｸﾞﾗｳﾝﾄﾞされていない内部 ) ﾎﾟｰﾄは、回路の内側
に置かれ、2つの端子は隣接した金属図形の間に接続されています。こ
のﾎﾟｰﾄを下図に図解します。内部ﾎﾟｰﾄは、そのﾎﾟｰﾄがどちらに向かって
いるかによって、ﾎﾟｰﾄの左または下に負の端子を持っています。この
ﾎﾟｰﾄは emでﾃﾞｨｴﾝﾍﾞｯﾄﾞすることができますが、ﾕｰｻﾞは参照面や
ｷｬﾘﾌﾞﾚｰｼｮﾝ長は設定しません。

図 a)では、この ungrounded-internal ﾎﾟｰﾄは同じ広さの 2つの図形の間に
接続されています。これは、 ungrounded-internal ﾎﾟｰﾄにとっては必要条件
ではありません。こうしたﾎﾟｰﾄは図 b)のように広さの異なる図形であっ
ても境を接していればよいわけです。 上記の 2つの条件の違いは、図形
の広さが異なったものが接続している時には、ﾃﾞｨｴﾝﾍﾞｯﾄﾞで使うｽﾀﾝ　
ﾀﾞｰﾄﾞが増える（従ってより時間がかかる）という違いがあるだけです。

１つの図形の端にこのﾎﾟｰﾄを置くことはできません。このﾎﾟｰﾄは
ｸﾞﾗｳﾝﾄﾞに接地していないので、ﾕｰｻﾞが結果を解釈する時にかなり注意
しなくてはいけません。

Ungrounded-internal ﾎﾟｰﾄを追加するには、標準 box wall ﾎﾟｰﾄを追加するの
と同じ方法で行います。詳細は、101 ﾍﾟｰｼﾞをご覧ください。
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Via Ports
Via ﾎﾟｰﾄは回路のあるﾚﾍﾞﾙの上に描かれた図形に接続された１つの端子と、その
図形の上か下の回路基板上のもう 1つの図形に接続された端子からなります。
Viaについての詳細は、第 18章の “Vias and 3-D Structures”をご覧ください。ﾎﾟｰﾄが
回路の内側の置きたい場所にある時は、2つの層の間に via を設置し、ﾎﾟｰﾄを
ｴｯｼﾞ viaに追加します。この種類のﾎﾟｰﾄを以下に示します。

Emは via ﾎﾟｰﾄをﾃﾞｨｴﾝﾍﾞｯﾄﾞできません。しかし、 via ﾎﾟｰﾄと他の種類のﾎﾟｰﾄが両
方含まれた回路であれば、他の種類のﾎﾟｰﾄはﾃﾞｨｴﾝﾍﾞｯﾄﾞできます。Em では、
回路内にあるその他のﾎﾟｰﾄすべてを区別し、ﾃﾞｨｴﾝﾍﾞｯﾄﾞしますが、ﾃﾞｨｴﾝﾍﾞｯﾄﾞし
ない via ﾎﾟｰﾄは除いて計算します

例題ﾌｧｲﾙ Dual_patchは、ﾊﾟｯﾁｱﾝﾃﾅで使用される via ﾎﾟｰﾄの例です。この例題ﾌｧｲﾙ
は Sonnetの例題ﾌｧｲﾙの中にあります。

Grounded ﾎﾟｰﾄが必要なほとんどの場合、特に auto-grounded ﾎﾟｰﾄをﾃﾞｨｴﾝ ﾍﾞｯﾄﾞで
きるので、次の項で述べる auto-grounded ﾎﾟｰﾄを使うことになります。Via ﾎﾟｰﾄが

Level 0
+

-
1

Via Port

Upper Polygon

Lower Polygon

標準の via ﾎﾟｰﾄのついた回路の例。回路の囲まれた領域
の横から見た様子が図の右に示されています。
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最も使われるのは、回路の中で隣接する 2つの層の間 にﾎﾟｰ ﾄをつけたい時か、
またはｸﾞﾗｳﾝﾄﾞの下よりもﾎﾞｯｸｽのｶﾊﾞｰにﾎﾟｰﾄをつけたい時の 2つの場合です。

Adding Via Ports
1 Via ﾎﾟｰﾄを追加するにはまず、viaで結合させる隣接したﾚﾍﾞﾙの上で 2つ

の図形を作ります。Via の作り方については　第 18章の “Vias and 3-D 
Structures”をご覧ください。

2 次にproject editorのﾂｰﾙﾎﾞｯｸｽのAdd Port をｸﾘｯｸし、 Add Port ﾓｰﾄﾞに入りま
す。

3 ﾎﾟｰﾄを追加する下のﾚﾍﾞﾙの図形のｴｯｼﾞ via の上でｸﾘｯｸします。その例を
前ﾍﾟｰｼﾞの図に示します。

Automatic-Grounded Ports
Automatic-grounded ﾎﾟｰﾄは回路の内部で使われる特殊なﾎﾟｰﾄです。この種類の
ﾎﾟｰﾄはﾎﾞｯｸｽの内側にある金属図形の端に接続している端子と、間にあるすべて
の誘電体層を通ってｸﾞﾗｳﾝﾄﾞ面に接続している端子から成っています。下に参照
面のついた auto-grounded ﾎﾟｰﾄを図解します。

多くの回路では、auto-grounded ﾎﾟｰﾄを追加しても emの解析時間全体に
は少しも影響ありません。しかし、回路によっては  auto-grounded ﾎﾟｰﾄは
いくらか計算のｵｰﾊﾞﾍｯﾄﾞが要求され、これによって全体の解析時間が増

Auto-
grounded 
port
picture.
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えることがあります。従って標準の box-wall ﾎﾟｰﾄを使うよりも有利な場
合にのみ使ってください。Auto-grounded ﾎﾟｰﾄは次の場合に標準の box-
wall ﾎﾟｰﾄより便利です。

• 解析したい回路が上図のようにﾎﾟｰﾄとﾎﾞｯｸｽの壁面に直接通
るような給電線を配することができないﾚｲｱｳﾄの時、または、

• ﾎﾞｯｸｽの壁面に届くような大きな給電の構造が必要な時。も
し給電の構造のすべて、または一部分を削れるのであれば
auto-grounded ﾎﾟｰﾄを使えば、回路内のｻﾌﾞｾｸｼｮﾝの総数を減
らせるので解析時間や必要ﾒﾓﾘも少なくてすみます。

Auto-grounded ﾎﾟｰﾄは次に述べる特徴を除いては via ﾎﾟｰﾄに似ています。

• Via ﾎﾟｰﾄは誘電体を通して金属図形のｴｯｼﾞまで上方向に届く
viaを手入力でつくらなくてはなりません。 Auto-grounded 
ﾎﾟｰﾄではこの必要はありません。 Grounded ﾎﾟｰﾄが必要な場所
に Auto-grounded ﾎﾟｰﾄを配置するだけです。Emでは自動的に
回路内に auto-grounded ﾎﾟｰﾄがあることを見つけ、ﾎﾟｰﾄの端
子を適切に接続します。

• Auto-grounded ﾎﾟｰﾄは誘電体の層を通って、直接にｸﾞﾗｳﾝﾄﾞ面
に接続します。 Via ﾎﾟｰﾄは 2つの隣接している誘電体の層の
間を接続できるという自由度があります。

• Auto-grounded ﾎﾟｰﾄは ﾃﾞｨｴﾝﾍﾞｯﾄﾞｵﾌﾟｼｮﾝが使われている時に
ﾃﾞｨｴﾝﾍﾞｯﾄﾞできます（ via ﾎﾟｰﾄはできません）。

• 参照面は auto-grounded ﾎﾟｰﾄでｾｯﾄできますが、via ﾎﾟｰﾄではで
きません。

Special Considerations for Auto-Grounded Ports

Metal Under Auto-Grounded Ports

多層の回路では auto-grounded ﾎﾟｰﾄの真下に金属導体を設置することはで
きません。 Auto-grounded ﾎﾟｰﾄは、2端子のﾃﾞﾊﾞｲｽで、１つめの端子は
ｴｯｼﾞに接しており、2つめの端子はｸﾞﾗｳﾝﾄﾞに接しています。Emが  auto- 
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grounded ﾎﾟｰﾄがあると判断すると、emは自動的にこのように 2つの端子
を接続します。図形とｸﾞﾗｳﾝﾄﾞの間に複数の誘電体層を持つような回路
でもそうです。しかし、emがこのように処理するためには金属図形か
らｸﾞﾗｳﾝﾄﾞに直接につながらなくてはいけません。Auto-grounded ﾎﾟｰﾄが
ﾎﾟｰﾄとｸﾞﾗｳﾝﾄﾞの間に１つ以上誘電体層がある回路で使われる時には、
auto-grounded ﾎﾟｰﾄの真下には何も金属導体がないかどうかを emは必ず
ﾁｪｯｸします。もし金属導体があると、emはｴﾗｰﾒｾｯｾｰｼﾞを出し、ｽﾄｯﾌﾟし
てしまいます。

Edge of Metal Polygon is Lossless

Auto-grounded ﾎﾟｰﾄは回路の内側のどんな種類の金属図形の縁にも設置す
ることができます。図形内で使われる金属導体の損失値には何の制限も
ありません。しかし、ﾎﾟｰﾄの設置されている金属図形の縁に沿ったｾﾙに
ついては、emでは無損失でなくてはなりません。大抵の回路ではその
ことは解析結果にはほとんど影響ありません。しかし、ﾎﾟｰﾄが損失の高
い金属図形に設置されていると（例えば薄膜抵抗）、その図形の縁部の
ｾﾙは無損失となり、出力結果に影響してきます。

Require Short Distance to Ground

Auto-grounded ﾎﾟｰﾄは、ｸﾞﾗｳﾝﾄﾞ面までの距離を短くする必要があります。
Auto-grounded ﾎﾟｰﾄと基板(ｸﾞﾗｳﾝﾄﾞ面)の間の距離は  1/8 波長以下にするべ
きです。

Auto-Grounded Ports on Box-Wall

Auto-grounded ﾎﾟｰﾄは回路の内側で使われるように設計されています。
Auto-grounded ﾎﾟｰﾄがbox-wall上に置かれると、それは標準のbox-wallﾎﾟｰﾄ
のように扱われます。

Adding Auto-grounded Ports
1 Auto-grounded ﾎﾟｰﾄの追加は、101 ﾍﾟｰｼﾞで説明した標準ﾎﾟｰﾄを追

加する時のように操作していきます。

2 ﾎﾟｰﾄをｸﾘｯｸすると Modify ﾒﾆｭｰｵﾌﾟｼｮﾝが使えるようになります。
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3 Modify ⇒ Port Properties を選択すると下図のようなPort Attributes 
ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが出てきます。

4 Typeのﾄﾞﾛｯﾌﾟﾘｽﾄの中から Autognd を、ﾎﾟｰﾄは標準のﾎﾟｰﾄから
auto-grounded ﾎﾟｰﾄに変えることができます。この時、ﾎﾟｰﾄは
112 ﾍﾟｰｼﾞのﾎﾟｰﾄに似たものになっているはずです。

Creating Auto-grounded Ports: An Example

この節では回路に auto-grounded ﾎﾟｰﾄを追加を追加する方法を詳しく説明し
ます。

“標準の ”box-wallまたはungrounded-internal ﾎﾟｰﾄを追加するのと同じ方法
で回路に auto-grounded ﾎﾟｰﾄを追加します。違うのはﾎﾟｰﾄを追加した後に
“auto-grounded”の種類に変更しなくてはならない点だけです。

page 23
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回路に auto-grounded ﾎﾟｰﾄを追加する手順を以下に示します。

上に描かれた回路から始めることと仮定します。以下に 2つの “標準 ”
box-wall ﾎﾟｰﾄと2つの“auto-grounded”ﾎﾟｰﾄを上図に示された位置に設定す
る手順を説明します。

1 (Shift ｷｰを押したまま )Tools ⇒ Add Portを選択します。

2 ﾏｳｽを使って指示された図形のｴｯｼﾞの１つ１つをｸﾘｯｸします。そ
の結果は 116 ﾍﾟｰｼﾞに示したような回路になっているでしょう。4
つのﾎﾟｰﾄはすべて “標準 ”の種類のﾎﾟｰﾄになっています。

3 ESC ｷｰを押して pointer ﾓｰﾄﾞに戻ります。

Place Auto-Grounded Ports Here

Place Standard Box-Wall Ports Here

Example 
circuit with 
“standard” 
ports added to 
polygon 
edges.
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4 ﾏｳｽを使ってﾎﾟｰﾄ 3とﾎﾟｰﾄ 4を lasso（囲み指定）します。こうする
と選択したﾎﾟｰﾄが強調表示されます。

5 Modify ⇒ Port Properties を選択すると115ﾍﾟｰｼﾞの図のようなPort
Attributes ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽが出てきます。

6 Type ﾌｨｰﾙﾄﾞのﾄﾞﾛｯﾌﾟﾘｽﾄの中から Autogndを指定すると標準ﾎﾟｰﾄ
から auto-grounded に変わります。

7 Port Attributes ﾀﾞｲｱﾛｸﾞﾎﾞｯｸｽを終了するためにOK ﾎﾞﾀﾝをｸﾘｯｸしま
す。

この方法でﾎﾟｰﾄ 3とﾎﾟｰﾄ 4を変換すると回路は下図のようになります。

この回路には指定したかった位置に 2つの box-wall ﾎﾟｰﾄと 2つの auto-
grounded ﾎﾟｰﾄがついています。


